summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-14 23:15:39 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-14 23:21:16 +0200
commite7aac78ee906e799623419ea993e1eefbfec5733 (patch)
tree4c3718d8f0b6235c85f765e37a0318dc5808d2f9 /gnu/packages/tor.scm
parent748d3a2b8aabe63965bd71392e5e7bdd2ed1b6b0 (diff)
downloadguix-patches-e7aac78ee906e799623419ea993e1eefbfec5733.tar
guix-patches-e7aac78ee906e799623419ea993e1eefbfec5733.tar.gz
gnu: tor: Update to 0.4.6.5.
* gnu/packages/tor.scm (tor): Update to 0.4.6.5. [source]: Add a patch to fix building with GCC 7. * gnu/packages/patches/tor-fix-build-with-gcc-7.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 6e65c23e62..b18e057977 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -54,14 +54,15 @@
(define-public tor
(package
(name "tor")
- (version "0.4.5.9")
+ (version "0.4.6.5")
(source (origin
(method url-fetch)
(uri (string-append "https://dist.torproject.org/tor-"
version ".tar.gz"))
(sha256
(base32
- "0mh8yz6l7sl6kh9max76nk6rhlsq2lhwwvpiwlwnrlif21bf817k"))))
+ "1yacd7h7wg8n6wwrjmx2g9xjj24kj08j5sai9g7fm4cp1m73avbv"))
+ (patches (search-patches "tor-fix-build-with-gcc-7.patch"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags