summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-02 10:37:54 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-02 11:07:18 +0200
commite5778898288edcddc49db67d104ae76b8492da1f (patch)
tree9cbc594f7ecd9e9d95d492fe67c3a73dbef768a6 /gnu/packages/tor.scm
parent24832d2ebd16fac4f874c0c373856c46d54ffba5 (diff)
downloadguix-patches-e5778898288edcddc49db67d104ae76b8492da1f.tar
guix-patches-e5778898288edcddc49db67d104ae76b8492da1f.tar.gz
gnu: tor: Limit test suite adjustments to affected architectures.
This is a follow-up to 68d090002a1a5623494006fca3e2c2c97d3ff676. * gnu/packages/tor.scm (tor)[arguments]: Only add custom 'adjust-test-suite phase on aarch64, powerpc32.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index cb8fa7e6d0..f0e3849311 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -77,15 +77,18 @@
;; This is a style linter. It doesn't get to throw fatal errors.
(lambda _
(setenv "TOR_DISABLE_PRACTRACKER" "set")))
- (add-before 'check 'adjust-test-suite
- (lambda _
+ ,@(if (or (target-aarch64?)
+ (target-ppc32?))
;; Work around upstream issue relating to sandboxing and glibc-2.33.
;; This is similar to the issue the tor-sandbox-i686 patch fixes
;; but for other architectures.
;; https://gitlab.torproject.org/tpo/core/tor/-/issues/40381
;; https://gitlab.torproject.org/tpo/core/tor/-/merge_requests/446
- (substitute* "src/test/test_include.sh"
- ((".*Sandbox 1.*") "")))))))
+ `((add-before 'check 'adjust-test-suite
+ (lambda _
+ (substitute* "src/test/test_include.sh"
+ ((".*Sandbox 1.*") "")))))
+ '()))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python))) ; for tests