summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-06-18 09:37:06 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 09:39:35 +0200
commite418c3d076ec301a2deda42568035d75f5ed174d (patch)
treec44acd415ab11436ff23cb8d86102abe7d4ecbe8 /gnu/packages/tor.scm
parentf817a0c095f77ccd30a2b9e776bee9a92b1c45e6 (diff)
downloadguix-patches-e418c3d076ec301a2deda42568035d75f5ed174d.tar
guix-patches-e418c3d076ec301a2deda42568035d75f5ed174d.tar.gz
gnu: privoxy: Fix daemon with default configuration.
* gnu/packages/tor.scm (privoxy)[arguments]: Add --localstatedir=/var to configure flags. Patch default configuration to disable logging and thus allowing non-root users to use it. Signed-off-by: Pierre Neidhardt <mail@ambrevar.xyz>
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 2f2623b0e6..19ab5cf374 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -141,8 +142,28 @@ rejects UDP traffic from the application you're using.")
;; $out/etc/privoxy.
#:configure-flags (list (string-append "--sysconfdir="
(assoc-ref %outputs "out")
- "/etc/privoxy"))
- #:tests? #f))
+ "/etc/privoxy")
+ "--localstatedir=/var")
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-default-logging
+ (lambda _
+ (with-fluids ((%default-port-encoding "ISO-8859-1"))
+ ;; Do not create /var/run nor /var/log/privoxy/logfile.
+ (substitute* "GNUmakefile.in"
+ (("(logfile \\|\\| exit )1" _ match)
+ (string-append match "0"))
+ (("(\\$\\(DESTDIR\\)\\$\\(SHARE_DEST\\)) \\\\" _ match)
+ match)
+ ((".*\\$\\(LOG_DEST\\) \\$\\(DESTDIR\\)\\$\\(PID_DEST\\).*")
+ ""))
+ ;; Disable logging in the default configuration to allow for
+ ;; non-root users using it as is.
+ (substitute* "config"
+ (("^logdir") "#logdir")
+ (("^logfile") "#logfile")))
+ #t)))))
(inputs
`(("w3m" ,w3m)
("pcre" ,pcre)