summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 15:23:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:02 +0100
commitb41a05ce497d5ecc682cf46ce61aa2215193f9f6 (patch)
treedf76eaccd4a00fd741a66394a2bcf73e18dd7680 /gnu/packages/tor.scm
parentd8013ee221bd599474340899ffb5974796091955 (diff)
downloadguix-patches-b41a05ce497d5ecc682cf46ce61aa2215193f9f6.tar
guix-patches-b41a05ce497d5ecc682cf46ce61aa2215193f9f6.tar.gz
gnu: Remove work-arounds for bug 20765 (ensure uncompressed eggs).
Bug 20765 is solved since we build all Python packages using option "--single-version-externally-managed". * gnu/packages/bioinformatics.scm (pbtranscript-tofu): Remove configure-flags. (pepr): remove phase "disable-egg-generation". * gnu/packages/pdf.scm (reportlab): Remove configure-flags. * gnu/packages/python.scm (python-sphinx-rtd-theme, python2-elib.intl, python-pkgconfig, python-pytest-pep8, python-pytest-flakes): Remove configure-flags. (python-pillow) remove phase "disable-egg-generation". (python-libarchive-c) Remove patching setup.cfg. * gnu/packages/statistics.scm (python-patsy): remove phase "prevent-generation-of-egg-archive". * gnu/packages/tls.scm (python-acme): remove phase "disable-egg-compression". * gnu/packages/tor.scm (onionshare): Remove configure-flags.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index e6fbf6e005..fe079fb104 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -208,11 +208,7 @@ networks.")
;; After all the patching we run the tests after installing.
;; This is also a known issue:
;; https://github.com/micahflee/onionshare/issues/284
- (lambda _ (zero? (system* "nosetests" "test")))))
- ;; can't compress the egg because it expects to find all the resources
- ;; inside the egg as though it were a folder.
- #:configure-flags '("--single-version-externally-managed" "--root=/")
- ))
+ (lambda _ (zero? (system* "nosetests" "test")))))))
(native-inputs
`(("python-nose" ,python-nose)))
(inputs