summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-12-01 10:49:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-12-01 11:38:33 +0200
commit68d090002a1a5623494006fca3e2c2c97d3ff676 (patch)
treeab7d2896ecdcc67fa5bcd889518416a2ac618794 /gnu/packages/tor.scm
parent762643e0fc2b4c6fe06ac0e15f7352c85d801777 (diff)
downloadguix-patches-68d090002a1a5623494006fca3e2c2c97d3ff676.tar
guix-patches-68d090002a1a5623494006fca3e2c2c97d3ff676.tar.gz
gnu: tor: Fix build issue on some architectures.
* gnu/packages/tor.scm (tor)[arguments]: Add phase to remove sandbox during one of the tests.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 11b81a1234..cb8fa7e6d0 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -76,8 +76,16 @@
(add-before 'check 'skip-practracker
;; This is a style linter. It doesn't get to throw fatal errors.
(lambda _
- (setenv "TOR_DISABLE_PRACTRACKER" "set")
- #t)))))
+ (setenv "TOR_DISABLE_PRACTRACKER" "set")))
+ (add-before 'check 'adjust-test-suite
+ (lambda _
+ ;; Work around upstream issue relating to sandboxing and glibc-2.33.
+ ;; This is similar to the issue the tor-sandbox-i686 patch fixes
+ ;; but for other architectures.
+ ;; https://gitlab.torproject.org/tpo/core/tor/-/issues/40381
+ ;; https://gitlab.torproject.org/tpo/core/tor/-/merge_requests/446
+ (substitute* "src/test/test_include.sh"
+ ((".*Sandbox 1.*") "")))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python))) ; for tests