summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 13:00:37 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:50:51 +0100
commit15c661ec8ed90107690980758be6a88fe4c47061 (patch)
tree99687c2c8619cfe3125d8e9c1114c970f006d834 /gnu/packages/tor.scm
parentd77ade87fe2bdf41627a3dc432150c64567df486 (diff)
downloadguix-patches-15c661ec8ed90107690980758be6a88fe4c47061.tar
guix-patches-15c661ec8ed90107690980758be6a88fe4c47061.tar.gz
gnu: torsocks: Update to 2.3.0.
* gnu/packages/tor.scm (torsocks): Update to 2.3.0. [inputs]: Remove which. [arguments]: Update 'absolutize' substitutions.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index 9b66437a64..ec86d7d241 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -91,27 +91,24 @@ the application layer) you need to install @code{torsocks}.")
(define-public torsocks
(package
(name "torsocks")
- (version "2.2.0")
+ (version "2.3.0")
(source (origin
(method url-fetch)
(uri (string-append "https://people.torproject.org/~dgoulet/"
"torsocks/torsocks-" version ".tar.xz"))
(sha256
(base32
- "0byr9ga9w79qz4vp0m11sbmspad7fsal9wm67r4znzb7zb7cis19"))))
+ "08inrkap29gikb6sdmb58z43hw4abwrfw7ny40c4xzdkss0vkwdr"))))
(build-system gnu-build-system)
(inputs
- `(("which" ,which)
- ("libcap" ,libcap)))
+ `(("libcap" ,libcap)))
(arguments
`(#:phases (modify-phases %standard-phases
(add-after 'build 'absolutize
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/bin/torsocks"
- (("getcap=`.*`")
- (string-append "getcap=" (which "getcap")))
- (("`which")
- (string-append "`" (which "which"))))
+ (("getcap=.*")
+ (string-append "getcap=" (which "getcap") "\n")))
#t)))))
(home-page "https://www.torproject.org/")
(synopsis "Use socks-friendly applications with Tor")