summaryrefslogtreecommitdiff
path: root/gnu/packages/tor.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-08-15 11:21:22 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-15 11:21:22 +0200
commit0e53328a8a6e78687436658bb96c0da9802dfaac (patch)
tree504730348cb1d2fc75fe24af1c85003966c680a5 /gnu/packages/tor.scm
parentae549cf48f14efc61a5bf7cec6203708dbb55068 (diff)
downloadguix-patches-0e53328a8a6e78687436658bb96c0da9802dfaac.tar
guix-patches-0e53328a8a6e78687436658bb96c0da9802dfaac.tar.gz
gnu: torsocks: Wrap lines.
* gnu/packages/tor.scm (torsocks)[source, arguments]: Wrap long lines and remove a trailing #t.
Diffstat (limited to 'gnu/packages/tor.scm')
-rw-r--r--gnu/packages/tor.scm30
1 files changed, 16 insertions, 14 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index d71374542b..36ad5e765a 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -162,26 +162,28 @@ This package only provides a client to the Tor Network.")))
(package
(name "torsocks")
(version "2.4.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v"
- version "/torsocks-v" version ".tar.bz2"))
- (sha256
- (base32
- "1a7k3njdhp7dz603knhisna1zvxw35j3g213p6dvczv9bcjy7cjl"))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.torproject.org/tpo/core/torsocks/-/archive/v"
+ version "/torsocks-v" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1a7k3njdhp7dz603knhisna1zvxw35j3g213p6dvczv9bcjy7cjl"))))
(build-system gnu-build-system)
(inputs
(list libcap))
(native-inputs
(list autoconf automake libtool))
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'build 'absolutize
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "src/bin/torsocks"
- (("getcap=.*")
- (string-append "getcap=" (which "getcap") "\n")))
- #t)))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'absolutize
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/bin/torsocks"
+ (("getcap=.*")
+ (string-append "getcap=" (which "getcap") "\n"))))))))
(home-page "https://www.torproject.org/")
(synopsis "Transparently route an application's traffic through Tor.")
(description