summaryrefslogtreecommitdiff
path: root/gnu/packages/tmux.scm
diff options
context:
space:
mode:
authorMatthew James Kraai <kraai@ftbfs.org>2021-07-05 03:22:32 -0700
committerLudovic Courtès <ludo@gnu.org>2021-07-23 17:02:29 +0200
commitefcd669c5ad2cb471e583172c5f54a205b3dcaa5 (patch)
tree9922e0c9a99c7050a95f97dc6079ecb5f60a43c0 /gnu/packages/tmux.scm
parent7273b669458db959dfa87edc61f916bab91c6112 (diff)
downloadguix-patches-efcd669c5ad2cb471e583172c5f54a205b3dcaa5.tar
guix-patches-efcd669c5ad2cb471e583172c5f54a205b3dcaa5.tar.gz
gnu: tmux-themepack: Update to 1.1.0.
* gnu/packages/tmux.scm (tmux-themepack): Update to 1.1.0. [arguments]: Install only selected files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tmux.scm')
-rw-r--r--gnu/packages/tmux.scm62
1 files changed, 32 insertions, 30 deletions
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index 09040e106d..7dc977d820 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -67,36 +67,38 @@ continue running in the background, then later reattached.")
(license license:isc)))
(define-public tmux-themepack
- (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
- (revision "1"))
- (package
- (name "tmux-themepack")
- (version (git-version "0.0.0" revision commit)) ; no version tags
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jimeh/tmux-themepack")
- (commit commit)))
- (sha256
- (base32
- "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (string-append
- (assoc-ref outputs "out")
- "/share/" ,name "-" ,version)))
- (copy-recursively "." out)))))))
- (home-page "https://github.com/jimeh/tmux-themepack")
- (synopsis "Collection of themes for Tmux")
- (description "A collection of various themes for Tmux.")
- (license license:wtfpl2))))
+ (package
+ (name "tmux-themepack")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimeh/tmux-themepack")
+ (commit version)))
+ (sha256
+ (base32
+ "00dmd16ngyag3n46rbnl9vy82ih6g0y02yfwkid32a1c8vdbvb3z"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append
+ (assoc-ref outputs "out")
+ "/share/" ,name)))
+ (copy-recursively "powerline" (string-append out "/powerline"))
+ (for-each (lambda (file) (copy-file file (string-append out "/" file)))
+ '("basic.tmuxtheme"
+ "default.tmuxtheme"
+ "themepack.tmux"))))))))
+ (home-page "https://github.com/jimeh/tmux-themepack")
+ (synopsis "Collection of themes for Tmux")
+ (description "A collection of various themes for Tmux.")
+ (license license:wtfpl2)))
(define-public tmuxifier
(package