summaryrefslogtreecommitdiff
path: root/gnu/packages/tmux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 18:14:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-11 18:15:49 +0100
commitc07c8892eec7b4a534a5f7ff01626450ffe66443 (patch)
treef3fcbb21ff49b7609fc9e5b16b149a0d1c8fd8a4 /gnu/packages/tmux.scm
parent9e06166da2e88d786de4c480b2bd5f6136144466 (diff)
downloadguix-patches-c07c8892eec7b4a534a5f7ff01626450ffe66443.tar
guix-patches-c07c8892eec7b4a534a5f7ff01626450ffe66443.tar.gz
gnu: python-libtmux: Update to 0.8.5.
* gnu/packages/tmux.scm (python-libtmux): Update to 0.8.5. [arguments]: Set LANG to make the test suite pass.
Diffstat (limited to 'gnu/packages/tmux.scm')
-rw-r--r--gnu/packages/tmux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index de55c0b188..95a31f80fd 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -145,7 +145,7 @@ windows.")
(define-public python-libtmux
(package
(name "python-libtmux")
- (version "0.8.3")
+ (version "0.8.5")
(source
(origin
(method git-fetch)
@@ -155,7 +155,7 @@ windows.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "18dqqd3jmgq3jb1l3xpgywlh4x82mzjxch61gwnlhfaqx5mzvjph"))))
+ (base32 "1vrd99kl2gsk49mvbp6k7l1k7r96vf1fczsqclb62yd4hdpp7zaa"))))
(build-system python-build-system)
(propagated-inputs
`(("procps" ,procps))) ;tests need top
@@ -171,6 +171,8 @@ windows.")
(setenv "PYTHONPATH"
(string-append (getcwd) "/build/lib:"
(getenv "PYTHONPATH")))
+ ;; Fix <https://github.com/tmux-python/libtmux/issues/265>.
+ (setenv "LANG" "en_US.utf8")
;; Skip tests that I suspect fail because of a change
;; in behavior in tmux 3 from tmux 2
;; https://github.com/tmux-python/libtmux/issues/281