summaryrefslogtreecommitdiff
path: root/gnu/packages/tmux.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
committerMarius Bakke <marius@gnu.org>2021-07-29 22:34:57 +0200
commitb029be2ee0f81cdcbc14240ff426408085ab0a40 (patch)
treeed6d0e1bfdadfd28e1eb804e43763b793baa0b42 /gnu/packages/tmux.scm
parentbc55f3091bac4677df0cf020381c554921fea179 (diff)
parentffb381856d0c6cc1a557b789f6b377cfa17002a0 (diff)
downloadguix-patches-b029be2ee0f81cdcbc14240ff426408085ab0a40.tar
guix-patches-b029be2ee0f81cdcbc14240ff426408085ab0a40.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/emacs-xyz.scm gnu/packages/gpodder.scm gnu/packages/music.scm gnu/packages/patches/glibc-bootstrap-system.patch gnu/packages/python-xyz.scm gnu/packages/shells.scm gnu/packages/statistics.scm
Diffstat (limited to 'gnu/packages/tmux.scm')
-rw-r--r--gnu/packages/tmux.scm63
1 files changed, 33 insertions, 30 deletions
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index c9ede9e25b..e0aa2b3751 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -67,36 +67,39 @@ continue running in the background, then later reattached.")
(license license:isc)))
(define-public tmux-themepack
- (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
- (revision "1"))
- (package
- (name "tmux-themepack")
- (version (git-version "0.0.0" revision commit)) ; no version tags
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/jimeh/tmux-themepack")
- (commit commit)))
- (sha256
- (base32
- "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no test suite
- #:phases (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (string-append
- (assoc-ref outputs "out")
- "/share/" ,name "-" ,version)))
- (copy-recursively "." out)))))))
- (home-page "https://github.com/jimeh/tmux-themepack")
- (synopsis "Collection of themes for Tmux")
- (description "A collection of various themes for Tmux.")
- (license license:wtfpl2))))
+ (package
+ (name "tmux-themepack")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jimeh/tmux-themepack")
+ (commit version)))
+ (sha256
+ (base32
+ "00dmd16ngyag3n46rbnl9vy82ih6g0y02yfwkid32a1c8vdbvb3z"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no test suite
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (string-append
+ (assoc-ref outputs "out")
+ "/share/" ,name)))
+ (copy-recursively "powerline" (string-append out "/powerline"))
+ (for-each (lambda (file) (copy-file file (string-append out "/" file)))
+ '("basic.tmuxtheme"
+ "default.tmuxtheme"
+ "themepack.tmux"))))))))
+ (home-page "https://github.com/jimeh/tmux-themepack")
+ (synopsis "Collection of themes for Tmux")
+ (description
+ "This package provides several themes for Tmux, the terminal multiplexer.")
+ (license license:wtfpl2)))
(define-public tmuxifier
(package