summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-07-05 12:50:47 -0400
committerLeo Famulari <leo@famulari.name>2022-07-06 14:28:24 -0400
commitfe24e0c29cfe69d0c1aec819ce1a7e96362bafe6 (patch)
tree865a80541789750661af1407bec0bf22f9afe6c1 /gnu/packages/tls.scm
parent39dcbc7fa3c02ff5c9682f25e1c29667dbfe7827 (diff)
downloadguix-patches-fe24e0c29cfe69d0c1aec819ce1a7e96362bafe6.tar
guix-patches-fe24e0c29cfe69d0c1aec819ce1a7e96362bafe6.tar.gz
gnu: OpenSSL 3.0.0: Update to 3.0.5 [fixes CVE-2022-2097 and CVE-2022-2274].
https://www.cve.org/CVERecord?id=CVE-2022-2097 https://www.cve.org/CVERecord?id=CVE-2022-2274 * gnu/packages/tls.scm (openssl-3.0): Update to 3.0.5.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index f65ae63379..1ee5400a9c 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -525,7 +525,7 @@ OpenSSL for TARGET."
(define-public openssl-3.0
(package
(inherit openssl)
- (version "3.0.4")
+ (version "3.0.5")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -538,7 +538,7 @@ OpenSSL for TARGET."
(patches (search-patches "openssl-3.0-c-rehash-in.patch"))
(sha256
(base32
- "03y0q2pzpkpgfgf74x4pf8gyar9d7pb0l0p7g2s0m2k6k8z88c98"))))
+ "0yja085lygkdxbf4k4rckkj9r24p8dgix8avqljnbbbixydqszda"))))
(arguments
(substitute-keyword-arguments (package-arguments openssl)
((#:phases phases '%standard-phases)