summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:33:09 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-18 14:37:26 +0000
commite486b2b674badc80627b11077b7df2ac1cab92d8 (patch)
tree5909547a69c4b185b878c8f0fe8152f1c01fef04 /gnu/packages/tls.scm
parent0df1eb029efe5ebe3f02e36fa650cae4aaba89ec (diff)
parent88badc074a5dbebf80115918cf6c0009075154d2 (diff)
downloadguix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar
guix-patches-e486b2b674badc80627b11077b7df2ac1cab92d8.tar.gz
Merge remote-tracking branch 'signed/master' into core-updates
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm83
1 files changed, 55 insertions, 28 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index fd60ef08d3..b7f3ddd953 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1143,39 +1143,39 @@ derived from Mozilla's collection.")
(license license:mpl2.0))))
(define-public s2n
- (package
- (name "s2n")
- (version "1.0.10")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url (string-append "https://github.com/awslabs/" name))
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ampvh2n235hhd9nabgjjvja7d5r5kj45q56ass1k8g52a6xg0jq"))))
- (build-system cmake-build-system)
- (arguments
- '(#:tests? #f ; tests fail to build for static library
- #:configure-flags
- '("-DBUILD_TESTING=OFF"
- "-DBUILD_SHARED_LIBS=ON")))
- (propagated-inputs
- `(("openssl" ,openssl)
- ("openssl:static" ,openssl "static")))
- (synopsis "SSL/TLS implementation in C99")
- (description
- "This library provides a C99 implementation of SSL/TLS. It is designed to
-be familiar to users of the widely-used POSIX I/O APIs. It supports blocking,
-non-blocking, and full-duplex I/O. There are no locks or mutexes.
+ (let* ((commit "7f43b102def1d52422f6c3e48d5cb3e6dd26c646")
+ (revision "1"))
+ (package
+ (name "s2n")
+ (version (git-version "1.0.10" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aws/s2n-tls")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06rqg0vcispi63cmcza9j7ix80l0w6wmbw81qlg4fq8l1lg9nyvl"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("openssl" ,openssl)
+ ("openssl:static" ,openssl "static")))
+ (synopsis "SSL/TLS implementation in C99")
+ (description
+ "This library provides a C99 implementation of SSL/TLS. It is designed
+to be familiar to users of the widely-used POSIX I/O APIs. It supports
+blocking, non-blocking, and full-duplex I/O. There are no locks or mutexes.
As it can be difficult to keep track of which encryption algorithms and
protocols are best to use, s2n-tls features a simple API to use the latest
default set of preferences. Remaining on a specific version for backwards
compatibility is also supported.")
- (home-page "https://github.com/awslabs/s2n")
- (license license:asl2.0)))
+ (home-page "https://github.com/aws/s2n-tls")
+ (license license:asl2.0))))
(define-public wolfssl
(package
@@ -1207,3 +1207,30 @@ and DTLS 1.2, is up to 20 times smaller than OpenSSL, and offers progressive
ciphers such as ChaCha20, Curve25519, NTRU, and Blake2b.")
(home-page "https://www.wolfssl.com/")
(license license:gpl2+))) ; Audit
+
+(define-public aws-lc
+ (let ((commit "d0a5455417d80e68581e197d95720c3fb25e3926")
+ (revision "0"))
+ (package
+ (name "aws-lc")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ysj3x1f2lcdvwzyb9x3waykz1j7r21viv5z5vgc0ja9xv7znm9g"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; re-enable but with go and perl dependencies
+ #:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (synopsis "General purpose cryptographic library")
+ (description "AWS libcrypto (aws-lc) contains portable C implementations
+of algorithms needed for TLS and common applications, and includes optimized
+assembly versions for x86 and ARM.")
+ (home-page "https://github.com/awslabs/aws-lc")
+ (license license:asl2.0))))