summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-07-01 14:37:50 +0000
committerLudovic Courtès <ludo@gnu.org>2021-10-16 00:01:57 +0200
commitda9272fa00fc124a31fe01aef10f057ee64b6b8a (patch)
tree7273f125776f66e79c5ce7d1051a5bcf1051c3ee /gnu/packages/tls.scm
parent02f849ad7a2cbaf2454628cca50de8987defb189 (diff)
downloadguix-patches-da9272fa00fc124a31fe01aef10f057ee64b6b8a.tar
guix-patches-da9272fa00fc124a31fe01aef10f057ee64b6b8a.tar.gz
gnu: Add aws-lc.
* gnu/packages/tls.scm (aws-lc): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 564e52086a..74a88e1b3d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -1205,3 +1205,30 @@ and DTLS 1.2, is up to 20 times smaller than OpenSSL, and offers progressive
ciphers such as ChaCha20, Curve25519, NTRU, and Blake2b.")
(home-page "https://www.wolfssl.com/")
(license license:gpl2+))) ; Audit
+
+(define-public aws-lc
+ (let ((commit "d0a5455417d80e68581e197d95720c3fb25e3926")
+ (revision "0"))
+ (package
+ (name "aws-lc")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ysj3x1f2lcdvwzyb9x3waykz1j7r21viv5z5vgc0ja9xv7znm9g"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; re-enable but with go and perl dependencies
+ #:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (synopsis "General purpose cryptographic library")
+ (description "AWS libcrypto (aws-lc) contains portable C implementations
+of algorithms needed for TLS and common applications, and includes optimized
+assembly versions for x86 and ARM.")
+ (home-page "https://github.com/awslabs/aws-lc")
+ (license license:asl2.0))))