summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-11 18:32:07 -0500
committerLeo Famulari <leo@famulari.name>2021-03-11 21:41:47 -0500
commitc3a7537396f11af7dd04c294714eb20980946083 (patch)
tree6c86f0547b0731ee98a69ef0b0370993cefe18d0 /gnu/packages/tls.scm
parent09c05fde523f3186d9e12ce3310139ecb69b78d7 (diff)
downloadguix-patches-c3a7537396f11af7dd04c294714eb20980946083.tar
guix-patches-c3a7537396f11af7dd04c294714eb20980946083.tar.gz
gnu: certbot, python-acme: Update to 1.13.0.
* gnu/packages/tls.scm (python-acme): Update to 1.13.0. [native-inputs]: Remove python-mock. [propagated-inputs]: Remove python-six. (certbot): Update to 1.13.0. [propagated-inputs]: Remove python-six. [arguments]: Remove 'build-documentation' phase.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm19
1 files changed, 4 insertions, 15 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index acabca5df3..4572b39aa1 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -576,13 +576,13 @@ netcat implementation that supports TLS.")
(package
(name "python-acme")
;; Remember to update the hash of certbot when updating python-acme.
- (version "1.12.0")
+ (version "1.13.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1wn2jvkg18z31nd060hfcp2yqvxjxykim2ybgaidv7qfsms38dma"))))
+ "1260a7bcgmha19drqzn6syz3cy61482b3w6lihgg1md6svgmfhkb"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -599,8 +599,7 @@ netcat implementation that supports TLS.")
(install-file "docs/_build/man/acme-python.1" man)
#t))))))
(native-inputs
- `(("python-mock" ,python-mock)
- ("python-pytest" ,python-pytest)
+ `(("python-pytest" ,python-pytest)
;; For documentation
("python-sphinx" ,python-sphinx)
("python-sphinxcontrib-programoutput" ,python-sphinxcontrib-programoutput)
@@ -608,7 +607,6 @@ netcat implementation that supports TLS.")
("texinfo" ,texinfo)))
(propagated-inputs
`(("python-josepy" ,python-josepy)
- ("python-six" ,python-six)
("python-requests" ,python-requests)
("python-requests-toolbelt" ,python-requests-toolbelt)
("python-pytz" ,python-pytz)
@@ -632,20 +630,12 @@ netcat implementation that supports TLS.")
(uri (pypi-uri "certbot" version))
(sha256
(base32
- "0nfzk6fzyfqy8lgs5lmxfndrdh5c2ljdvzj39rwvgg3r6ivkirsy"))))
+ "0n7lwajmlypkqgsd2cv74j41f5ag381skjlzhjfpsrppgnsl3kv4"))))
(build-system python-build-system)
(arguments
`(,@(substitute-keyword-arguments (package-arguments python-acme)
((#:phases phases)
`(modify-phases ,phases
- (replace 'build-documentation
- (lambda _
- ;; Fix building the manual page in 1.12.0:
- ;; https://github.com/certbot/certbot/issues/8633
- ;; TODO Remove the substitution in later releases.
- (substitute* "docs/conf.py"
- (("'man',") ""))
- (invoke "make" "-C" "docs" "man" "info")))
(replace 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -676,7 +666,6 @@ netcat implementation that supports TLS.")
("python-distro" ,python-distro)
("python-zope-component" ,python-zope-component)
("python-parsedatetime" ,python-parsedatetime)
- ("python-six" ,python-six)
("python-psutil" ,python-psutil)
("python-requests" ,python-requests)
("python-pytz" ,python-pytz)))