summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-14 13:12:57 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-14 15:57:40 +0200
commitc14c2ebaeec9defd4c0a152e7af4fe332cd3afd7 (patch)
tree5cf8e0d5f75607369ee6674ae6399f5f6f4fd19c /gnu/packages/tls.scm
parentaec20fae9747c541d2ff1512fe52f26428a89c02 (diff)
downloadguix-patches-c14c2ebaeec9defd4c0a152e7af4fe332cd3afd7.tar
guix-patches-c14c2ebaeec9defd4c0a152e7af4fe332cd3afd7.tar.gz
openssl: Remove trailing #t from phases.
* gnu/packages/tls.scm (openssl)[arguments]<#:phases>: Delete trailing #t. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index d7b8caca38..95fb261c9a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -364,8 +364,7 @@ required structures.")
((string-prefix? "powerpc64" target)
"linux-ppc64")
((string-prefix? "powerpc" target)
- "linux-ppc")))
- #t)))
+ "linux-ppc"))))))
'())
(replace 'configure
(lambda* (#:key outputs configure-flags #:allow-other-keys)
@@ -408,8 +407,7 @@ required structures.")
(for-each (lambda (file)
(install-file file slib)
(delete-file file))
- (find-files lib "\\.a$"))
- #t)))
+ (find-files lib "\\.a$")))))
(add-after 'install 'move-extra-documentation
(lambda* (#:key outputs #:allow-other-keys)
;; Move man3 pages and full HTML documentation to "doc".
@@ -422,8 +420,7 @@ required structures.")
(copy-recursively man3 man-target)
(delete-file-recursively man3)
(copy-recursively html html-target)
- (delete-file-recursively html)
- #t)))
+ (delete-file-recursively html))))
(add-after
'install 'remove-miscellany
(lambda* (#:key outputs #:allow-other-keys)
@@ -432,8 +429,7 @@ required structures.")
(let ((out (assoc-ref outputs "out")))
(delete-file-recursively (string-append out "/share/openssl-"
,(package-version this-package)
- "/misc"))
- #t))))))
+ "/misc"))))))))
(native-search-paths
(list (search-path-specification
(variable "SSL_CERT_DIR")