summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-07 17:53:32 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-29 15:31:18 +0200
commita9bcc6474667d6699500f03d69f9c8212a50d711 (patch)
treee8c8ff05790d553d09b0ca84e162c1747bdf4140 /gnu/packages/tls.scm
parent9ec263b415f0fccce47fa3cc35a1651017a265ea (diff)
downloadguix-patches-a9bcc6474667d6699500f03d69f9c8212a50d711.tar
guix-patches-a9bcc6474667d6699500f03d69f9c8212a50d711.tar.gz
gnu: gnutls: Remove net-tools for the Hurd.
* gnu/packages/tls.scm (gnutls)[inputs]: Remove net-tools for the Hurd.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index a057432f4b..eab832ce41 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,7 @@
#:use-module (gnu packages dns)
#:use-module (gnu packages gawk)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages hurd)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages libffi)
#:use-module (gnu packages libidn)
@@ -223,7 +225,8 @@ living in the same process.")
"debug"
"doc")) ;4.1 MiB of man pages
(native-inputs
- `(("net-tools" ,net-tools)
+ `(,@(if (hurd-target?) '()
+ `(("net-tools" ,net-tools)))
("pkg-config" ,pkg-config)
("which" ,which)
("datefudge" ,datefudge) ;tests rely on 'datefudge'