summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-28 23:53:26 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-01 00:00:16 +0100
commita92c6b1a2b5b8b69f248c732db4a11ddf130f0f1 (patch)
tree0e0c390d4eb7c7013d333ca1a98971d43f999c2e /gnu/packages/tls.scm
parent884910970332c92f77bd9e079b413e5683870f27 (diff)
downloadguix-patches-a92c6b1a2b5b8b69f248c732db4a11ddf130f0f1.tar
guix-patches-a92c6b1a2b5b8b69f248c732db4a11ddf130f0f1.tar.gz
gnu: openssl: Fix CVE-2019-1559.
* gnu/packages/tls.scm (openssl)[replacement]: New field. (openssl/fixed): New variable. (openssl-next)[inherit]: Inherit from it instead. * gnu/packages/patches/openssl-CVE-2019-1559.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c10b1a5320..6e91a46608 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;;
@@ -271,6 +271,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
+ (replacement openssl/fixed)
(version "1.0.2p")
(source (origin
(method url-fetch)
@@ -399,9 +400,18 @@ required structures.")
(license license:openssl)
(home-page "https://www.openssl.org/")))
+(define-public openssl/fixed
+ (hidden-package
+ (package
+ (inherit openssl)
+ (source (origin
+ (inherit (package-source openssl))
+ (patches (append (origin-patches (package-source openssl))
+ (search-patches "openssl-CVE-2019-1559.patch"))))))))
+
(define-public openssl-next
(package
- (inherit openssl)
+ (inherit openssl/fixed)
(name "openssl")
(version "1.1.1a")
(source (origin