summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-06-14 15:56:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-06-15 23:47:34 +0200
commit7892edc256e9f94acad57f698622b48dc741385f (patch)
tree9a7424dc6aef35c3556f3aa2eda0e60f65de9166 /gnu/packages/tls.scm
parent731d471a37bf23326ae3e042bb384f376f6fec99 (diff)
downloadguix-patches-7892edc256e9f94acad57f698622b48dc741385f.tar
guix-patches-7892edc256e9f94acad57f698622b48dc741385f.tar.gz
gnu: GnuTLS: Update to 3.6.8.
* gnu/packages/tls.scm (gnutls): Update to 3.6.8. [arguments]: Add "--with-guile-{site,site-ccache,extension-dir}" to #:configure-flags.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index eb853da1bf..912069c26d 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -161,7 +161,7 @@ living in the same process.")
(define-public gnutls
(package
(name "gnutls")
- (version "3.6.6")
+ (version "3.6.8")
(source (origin
(method url-fetch)
(uri
@@ -173,7 +173,7 @@ living in the same process.")
(patches (search-patches "gnutls-skip-trust-store-test.patch"))
(sha256
(base32
- "19rcfgsfxb01cyz8jxmmgkjqc7y5s97amajzyknk1i1amywcm6mv"))))
+ "10ry71sy8zbksa905bjryphafcg25gkmfa3pf48ripimar7990da"))))
(build-system gnu-build-system)
(arguments
`(; Ensure we don't keep a reference to this buggy software.
@@ -191,6 +191,15 @@ living in the same process.")
;; independently. This seems suboptimal.
"--with-default-trust-store-dir=/etc/ssl/certs"
+ ;; Tell the build system that we want Guile bindings installed to
+ ;; the output instead of Guiles own module directory.
+ (string-append "--with-guile-site-dir="
+ "$(datarootdir)/guile/site/$(GUILE_EFFECTIVE_VERSION)")
+ (string-append "--with-guile-site-ccache-dir="
+ "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
+ (string-append "--with-guile-extension-dir="
+ "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions")
+
;; FIXME: Temporarily disable p11-kit support since it is not
;; working on mips64el.
"--without-p11-kit")