summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-03 17:01:18 +0100
committerMarius Bakke <marius@gnu.org>2020-12-03 21:56:52 +0100
commit7177411c34be42aa1c539f462f0de191c74a5913 (patch)
tree9ba681891696743d63d3fb034327d012375e13df /gnu/packages/tls.scm
parentc5df560fd3762c0dbe99562f52223c73d445e597 (diff)
downloadguix-patches-7177411c34be42aa1c539f462f0de191c74a5913.tar
guix-patches-7177411c34be42aa1c539f462f0de191c74a5913.tar.gz
gnu: gnutls-dane: Inherit from newer GnuTLS.
Fixes <https://bugs.gnu.org/44914>. * gnu/packages/tls.scm (gnutls/dane): Inherit from GNUTLS/FIXED instead of GNUTLS.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 3b681426ad..28c6d8c392 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -287,7 +287,7 @@ required structures.")
;; Authentication of Named Entities. This is required for GNS functionality
;; by GNUnet and gnURL. This is done in an extra package definition
;; to have the choice between GnuTLS with Dane and without Dane.
- (package/inherit gnutls
+ (package/inherit gnutls/fixed
(name "gnutls-dane")
(inputs `(("unbound" ,unbound)
,@(package-inputs gnutls)))))