summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 00:10:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-06 00:50:16 -0400
commit63858f8c8bbcacddbe54f178942975d96b21fe3e (patch)
treed73d94ccd05f0e3884816de3c9279b10e450566a /gnu/packages/tls.scm
parentf72a1253a18798a25245b4124c1da35ed993e0d1 (diff)
downloadguix-patches-63858f8c8bbcacddbe54f178942975d96b21fe3e.tar
guix-patches-63858f8c8bbcacddbe54f178942975d96b21fe3e.tar.gz
gnu: gnutls: Update to 3.7.2.
The 3.7 branch, while not considered the "stable" branch upstream, has been adopted by most major GNU/Linux distributions such as Debian, Arch, openSUSE, etc. It has the benefit of receiving all the security fixes. * gnu/packages/tls.scm (gnutls): Update to 3.7.2. Remove trailing #t. [source]: Remove the gnutls-CVE-2021-20231.patch and gnutls-CVE-2021-20232.patch patches, now incorporated in the source. * gnu/packages/patches/gnutls-CVE-2021-20231.patch: Delete file. * gnu/packages/patches/gnutls-CVE-2021-20232.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register them.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 608a7d05b8..d9e62e8627 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -166,7 +166,7 @@ living in the same process.")
(define-public gnutls
(package
(name "gnutls")
- (version "3.6.15")
+ (version "3.7.2")
(source (origin
(method url-fetch)
;; Note: Releases are no longer on ftp.gnu.org since the
@@ -175,12 +175,10 @@ living in the same process.")
(version-major+minor version)
"/gnutls-" version ".tar.xz"))
(patches (search-patches "gnutls-skip-trust-store-test.patch"
- "gnutls-cross.patch"
- "gnutls-CVE-2021-20231.patch"
- "gnutls-CVE-2021-20232.patch"))
+ "gnutls-cross.patch"))
(sha256
(base32
- "0n0m93ymzd0q9hbknxc2ycanz49sqlkyyf73g9fk7n787llc7a0f"))))
+ "0li7mwjnm64mbxhacz0rpf6i9qd83f53fvbrx96alpqqk9d6qvk4"))))
(build-system gnu-build-system)
(arguments
`(#:tests? ,(not (or (%current-target-system)
@@ -228,8 +226,7 @@ living in the same process.")
(lambda _
(substitute* "tests/fastopen.sh"
(("^unset RETCODE")
- "exit 77\n")) ;skip
- #t))
+ "exit 77\n")))) ;skip
(add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
;; Copy the 4.1 MiB of section 3 man pages to "doc".
@@ -239,8 +236,7 @@ living in the same process.")
(oldman (string-append out "/share/man/man3")))
(mkdir-p mandir)
(copy-recursively oldman mandir)
- (delete-file-recursively oldman)
- #t))))))
+ (delete-file-recursively oldman)))))))
(outputs '("out" ;4.4 MiB
"debug"
"doc")) ;4.1 MiB of man pages