summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-24 22:32:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-24 22:36:39 +0300
commit5422920b9eaaa0c6bf779588748595c66ca86ba3 (patch)
tree3b1fe86499d1cb371b44efec54404c81b120576c /gnu/packages/tls.scm
parent68b22a85419a52dcdb47422c10f9575b5d332790 (diff)
downloadguix-patches-5422920b9eaaa0c6bf779588748595c66ca86ba3.tar
guix-patches-5422920b9eaaa0c6bf779588748595c66ca86ba3.tar.gz
gnu: openssl: Update replacement to 1.1.1l [security fixes].
* gnu/packages/tls.scm (openssl)[replacement]: Replace with 1.1.1l. (openssl-1.1.1k): Remove variable. (openssl-1.1.1l): Add variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index fb7d364c94..d52a88fc86 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -356,7 +356,7 @@ required structures.")
(package
(name "openssl")
(version "1.1.1j")
- (replacement openssl-1.1.1k)
+ (replacement openssl-1.1.1l)
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -490,11 +490,11 @@ required structures.")
(license license:openssl)
(home-page "https://www.openssl.org/")))
-;; Replacement package to fix CVE-2021-3449 and CVE-2021-3450.
-(define openssl-1.1.1k
+;; Replacement package to fix multiple CVEs.
+(define openssl-1.1.1l
(package
(inherit openssl)
- (version "1.1.1k")
+ (version "1.1.1l")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -507,7 +507,7 @@ required structures.")
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))
(sha256
(base32
- "1rdfzcrxy9y38wqdw5942vmdax9hjhgrprzxm42csal7p5shhal9"))))))
+ "1lbblxps2fhmz7bqh058iywh5wxfignbfx1s1kz2fj63b5g3wyhb"))))))
;; We will not add any new uses of this package. If you add new code that uses
;; this package, your change will be reverted!