summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-01 12:59:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-10 16:23:17 +0300
commit3a73399ee86e56f615ef09118b0c27b9049bfe81 (patch)
tree3ea37b75b874f093b94107d1834bc405880d0b30 /gnu/packages/tls.scm
parentb591052866e3956b543d130362d2f12fee0255e8 (diff)
downloadguix-patches-3a73399ee86e56f615ef09118b0c27b9049bfe81.tar
guix-patches-3a73399ee86e56f615ef09118b0c27b9049bfe81.tar.gz
gnu: openssl: Fix build on riscv64-linux.
* gnu/packages/tls.scm (openssl)[arguments]: On riscv64-linux use a custom 'check phase to skip a failing test. (target->openssl-target): Add case for riscv64-linux.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 9e2b4419bd..7858f06e9a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -358,7 +358,10 @@ OpenSSL for TARGET."
((string-prefix? "powerpc64" target)
"linux-ppc64")
((string-prefix? "powerpc" target)
- "linux-ppc")))
+ "linux-ppc")
+ ((string-prefix? "riscv64" target)
+ ;; linux64-riscv64 isn't recognized until 3.0.0.
+ "linux-generic64")))
(define-public openssl
(package
@@ -404,7 +407,8 @@ OpenSSL for TARGET."
#~())
;; This test seems to be dependant on kernel features.
;; https://github.com/openssl/openssl/issues/12242
- #$@(if (target-arm?)
+ #$@(if (or (target-arm?)
+ (target-riscv64?))
#~((replace 'check
(lambda* (#:key tests? test-target #:allow-other-keys)
(when tests?