summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-16 16:45:18 -0400
committerLeo Famulari <leo@famulari.name>2021-04-16 16:57:27 -0400
commit0cb4032f9a799e5b1a4f35b7a1881c1b69104466 (patch)
tree236de35b457cf0a8b8d81b2db21f5dd3fa15252c /gnu/packages/tls.scm
parentc3926120ba5ea76f531541b7926ccb6739575e0e (diff)
downloadguix-patches-0cb4032f9a799e5b1a4f35b7a1881c1b69104466.tar
guix-patches-0cb4032f9a799e5b1a4f35b7a1881c1b69104466.tar.gz
gnu: OpenSSL: Absorb grafted replacement.
* gnu/packages/tls.scm (openssl): Update to 1.1.1j. [replacement]: Remove field. (openssl/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm23
1 files changed, 2 insertions, 21 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 25493cc7ca..25dcdd7228 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -296,8 +296,7 @@ required structures.")
(define-public openssl
(package
(name "openssl")
- (replacement openssl/fixed)
- (version "1.1.1i")
+ (version "1.1.1j")
(source (origin
(method url-fetch)
(uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -310,7 +309,7 @@ required structures.")
(patches (search-patches "openssl-1.1-c-rehash-in.patch"))
(sha256
(base32
- "0hjj1phcwkz69lx1lrvr9grhpl4y529mwqycqc1hdla1zqsnmgp8"))))
+ "1gw17520vh13izy1xf5q0a2fqgcayymjjj5bk0dlkxndfnszrwma"))))
(build-system gnu-build-system)
(outputs '("out"
"doc" ;6.8 MiB of man3 pages and full HTML documentation
@@ -431,24 +430,6 @@ required structures.")
(license license:openssl)
(home-page "https://www.openssl.org/")))
-(define-public openssl/fixed
- (package
- (inherit openssl)
- (version "1.1.1k")
- (source (origin
- (method url-fetch)
- (uri (list (string-append "https://www.openssl.org/source/openssl-"
- version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/"
- "openssl-" version ".tar.gz")
- (string-append "ftp://ftp.openssl.org/source/old/"
- (string-trim-right version char-set:letter)
- "/openssl-" version ".tar.gz")))
- (patches (search-patches "openssl-1.1-c-rehash-in.patch"))
- (sha256
- (base32
- "1rdfzcrxy9y38wqdw5942vmdax9hjhgrprzxm42csal7p5shhal9"))))))
-
(define-public openssl-1.0
(package
(inherit openssl)