summaryrefslogtreecommitdiff
path: root/gnu/packages/tls.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-02-27 08:52:23 -0500
committerMark H Weaver <mhw@netris.org>2016-02-27 08:52:23 -0500
commit048ec1a8b092a87de08bfe410be65642522b63ed (patch)
tree1279c4fa3fd09805dbfe06be3514879aa38d503e /gnu/packages/tls.scm
parentfe5f687284889eeff3c1b73edab0aa26e58c3bc5 (diff)
parentb35461748b20d0172744974b39e7d9d033400c51 (diff)
downloadguix-patches-048ec1a8b092a87de08bfe410be65642522b63ed.tar
guix-patches-048ec1a8b092a87de08bfe410be65642522b63ed.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/tls.scm')
-rw-r--r--gnu/packages/tls.scm98
1 files changed, 74 insertions, 24 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 703cb299e1..4f2c7af3de 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -73,7 +73,7 @@ specifications.")
(source
(origin
(method url-fetch)
- (uri (string-append "http://p11-glue.freedesktop.org/releases/p11-kit-"
+ (uri (string-append "https://p11-glue.freedesktop.org/releases/p11-kit-"
version ".tar.gz"))
(sha256
(base32
@@ -318,57 +318,107 @@ security, and applying best practice development processes.")
"file://COPYING"
"See COPYING in the distribution.")))))
-(define-public acme
+(define-public python-acme
(package
- (name "acme")
- (version "0.2.0")
+ (name "python-acme")
+ (version "0.4.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "acme" version))
(sha256
(base32
- "1xcbywzrwrj2cmqhaj4k6b11wfkbm3i7za2k9j1sd74rs1zh5abl"))))
+ "173j2zkslh43fzf3wkl1jdzfjry361m0mhlc3jpwp7hk7lrclzjg"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2))
- ;; TODO: Add optional inputs for testing and building documentation.
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'disable-egg-compression
+ (lambda _
+ ;; Do not compress the egg.
+ ;; See <http://bugs.gnu.org/20765>.
+ (let ((port (open-file "setup.cfg" "a")))
+ (display "\n[easy_install]\nzip_ok = 0\n"
+ port)
+ (close-port port)
+ #t)))
+ (add-after 'install 'docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man (string-append out "/share/man/man1"))
+ (info (string-append out "/info")))
+ (and (zero? (system* "make" "-C" "docs" "man" "info"))
+ (install-file "docs/_build/texinfo/acme-python.info" info)
+ (install-file "docs/_build/man/acme-python.1" man)
+ #t)))))))
+ ;; TODO: Add optional inputs for testing.
(native-inputs
- `(("python2-mock" ,python2-mock)
- ("python2-setuptools" ,python2-setuptools)))
+ `(("python-mock" ,python-mock)
+ ;; For documentation
+ ("python-sphinx" ,python-sphinx)
+ ("python-sphinxcontrib-programoutput" ,python-sphinxcontrib-programoutput)
+ ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)
+ ("python-setuptools" ,python-setuptools)
+ ("texinfo" ,texinfo)))
(propagated-inputs
- `(("python2-ndg-httpsclient" ,python2-ndg-httpsclient)
- ("python2-werkzeug" ,python2-werkzeug)
- ("python2-six" ,python2-six)
- ("python2-requests" ,python2-requests)
- ("python2-pytz" ,python2-pytz)
- ("python2-pyrfc3339" ,python2-pyrfc3339)
- ("python2-pyasn1" ,python2-pyasn1)
- ("python2-cryptography" ,python2-cryptography)
- ("python2-pyopenssl" ,python2-pyopenssl)))
+ `(("python-ndg-httpsclient" ,python-ndg-httpsclient)
+ ("python-werkzeug" ,python-werkzeug)
+ ("python-six" ,python-six)
+ ("python-requests" ,python-requests)
+ ("python-pytz" ,python-pytz)
+ ("python-pyrfc3339" ,python-pyrfc3339)
+ ("python-pyasn1" ,python-pyasn1)
+ ("python-cryptography" ,python-cryptography)
+ ("python-pyopenssl" ,python-pyopenssl)))
(home-page "https://github.com/letsencrypt/letsencrypt")
(synopsis "ACME protocol implementation in Python")
(description "ACME protocol implementation in Python")
(license license:asl2.0)))
+(define-public python2-acme
+ (package-with-python2 python-acme))
+
(define-public letsencrypt
(package
(name "letsencrypt")
- (version "0.2.0")
+ (version "0.4.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "letsencrypt" version))
(sha256
(base32
- "0q57ylx00b6kl9zvawgag5yl03vlv1cjhp18xm96682pdibbgjci"))))
+ "1wwq8yvfdybf4d0gv4yfddkrg865s7rhng5xg563kks4wza1a2wp"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2))
- ;; TODO: Add optional inputs for testing building documentation.
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'docs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (man1 (string-append out "/share/man/man1"))
+ (man7 (string-append out "/share/man/man7"))
+ (info (string-append out "/info")))
+ (substitute* "docs/man/letsencrypt.rst"
+ (("letsencrypt --help all")
+ (string-append out "/bin/letsencrypt" " --help all")))
+ (and
+ (zero? (system* "make" "-C" "docs" "man" "info"))
+ (install-file "docs/_build/texinfo/LetsEncrypt.info" info)
+ (install-file "docs/_build/man/letsencrypt.1" man1)
+ (install-file "docs/_build/man/letsencrypt.7" man7)
+ #t)))))))
+ ;; TODO: Add optional inputs for testing.
(native-inputs
`(("python2-nose" ,python2-nose)
- ("python2-mock" ,python2-mock)))
+ ("python2-mock" ,python2-mock)
+ ;; For documentation
+ ("python2-sphinx" ,python2-sphinx)
+ ("python2-sphinx-rtd-theme" ,python2-sphinx-rtd-theme)
+ ("python2-sphinx-repoze-autointerface" ,python2-sphinx-repoze-autointerface)
+ ("python2-sphinxcontrib-programoutput" ,python2-sphinxcontrib-programoutput)
+ ("texinfo" ,texinfo)))
(propagated-inputs
- `(("acme" ,acme)
+ `(("python2-acme" ,python2-acme)
("python2-zope-interface" ,python2-zope-interface)
("python2-pythondialog" ,python2-pythondialog)
("python2-pyrfc3339" ,python2-pyrfc3339)