summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-08 10:48:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-08 10:49:19 +0200
commitdd00e0919fcecd895ff4e5a646cf068f46ff8d12 (patch)
treeffe6cedaa428aaddfd4cde82a149498a5eb54e65 /gnu/packages/time.scm
parent12a24ee878d68c36f44b4c48cd9c15b4acb87060 (diff)
downloadguix-patches-dd00e0919fcecd895ff4e5a646cf068f46ff8d12.tar
guix-patches-dd00e0919fcecd895ff4e5a646cf068f46ff8d12.tar.gz
gnu: time: Update to 1.8.
* gnu/packages/time.scm (time): Update to 1.8. [arguments]: Remove custom 'configure phase.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 58055cd13e..e390445fdd 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Ben Woodcroft <donttrustben@gmail.com>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,7 +30,7 @@
(define-public time
(package
(name "time")
- (version "1.7")
+ (version "1.8")
(source
(origin
(method url-fetch)
@@ -37,20 +38,8 @@
version ".tar.gz"))
(sha256
(base32
- "0va9063fcn7xykv658v2s9gilj2fq4rcdxx2mn2mmy1v4ndafzp3"))))
+ "06rfg8dn0q2r8pdq8i6brrs6rqrsgvkwbbl4kfx3a6lnal0m8bwa"))))
(build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)))))))))
(home-page "https://www.gnu.org/software/time/")
(synopsis "Run a command, then display its resource usage")
(description