summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-28 05:18:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-28 13:59:03 +0100
commitdb3e631db8fe0d6c833974ed556bddd5d13ee0f8 (patch)
treeded36dfb2ddf17c20e6e41cc73376cc75c1d7b79 /gnu/packages/time.scm
parent2441239842fa6f786008e8c75651342b2c0172d2 (diff)
downloadguix-patches-db3e631db8fe0d6c833974ed556bddd5d13ee0f8.tar
guix-patches-db3e631db8fe0d6c833974ed556bddd5d13ee0f8.tar.gz
gnu: python-monotonic: Update to 1.4.
* gnu/packages/time.scm (python-monotonic): Update to 1.4. [source]: Use PYPI-URI. [arguments]: Explicitly disable tests.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index a54524087f..59414f6d7c 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -264,18 +264,16 @@ ISO 8601 dates, time and duration.")
(define-public python-monotonic
(package
(name "python-monotonic")
- (version "0.3")
+ (version "1.4")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://pypi.python.org/packages/source/m/monotonic/monotonic-"
- version
- ".tar.gz"))
+ (uri (pypi-uri "monotonic" version))
(sha256
(base32
- "0yz0bcbwx8r2c01czzfpbrxddynxyk9k95jj8h6sgcb7xmfvl998"))))
+ "110zd5ld3nchdjds34r95lzs1csmmv81pli2px8l1k8qnpai29m0"))))
(build-system python-build-system)
+ (arguments '(#:tests? #f)) ;no tests
(home-page "https://github.com/atdt/monotonic")
(synopsis "Implementation of time.monotonic() for Python 2 & < 3.3")
(description