summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-17 12:16:09 -0500
committerLeo Famulari <leo@famulari.name>2021-12-17 12:41:03 -0500
commitd080368cb5159613a1ff6611e55e09b62977383e (patch)
treec15b0dc0f534a30824aabd020c10d1b05accb7a9 /gnu/packages/time.scm
parent9eee025bf873d727129d94da61c7baaf7a70a71c (diff)
downloadguix-patches-d080368cb5159613a1ff6611e55e09b62977383e.tar
guix-patches-d080368cb5159613a1ff6611e55e09b62977383e.tar.gz
gnu: datefudge: Add a backup source URI.
This tarball disappeared upstream. * gnu/packages/time.scm (datefudge)[source]: Add backup URI.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 728f5ebce7..97de5485ef 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -465,6 +465,8 @@ datetime type.")
(define-public datefudge
(package
(name "datefudge")
+ ;; XXX When updating this package, make sure to do something about the
+ ;; archive.org backup URI.
(version "1.23")
(source (origin
;; Source code is available from
@@ -472,9 +474,17 @@ datetime type.")
;; for bootstrapping reasons, we do not rely on 'git-fetch' here
;; (since Git -> GnuTLS -> datefudge).
(method url-fetch)
- (uri (string-append
- "mirror://debian/pool/main/d/datefudge/datefudge_"
- version ".tar.xz"))
+ (uri (list
+ ;; For some reason this tarball was removed from Debian's
+ ;; servers. Remove this archive.org URL when updating
+ ;; datefudge, or add the new tarball to archive.org and
+ ;; update the URL.
+ (string-append
+ "https://archive.org/download/datefudge_" version
+ ".tar_202112/" "datefudge_" version ".tar.xz")
+ (string-append
+ "mirror://debian/pool/main/d/datefudge/datefudge_"
+ version ".tar.xz")))
(sha256
(base32
"0ifnlb0mc8qc2kb5042pbz0ns6rwcb7201di8wyrsphl0yhnhxiv"))