summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-08 23:44:06 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-09 11:58:52 +0200
commitb182121458c0126a05a41fec78a4f42472ba8081 (patch)
tree23bf94d87c43d7cbc7654ce897cd13b8cd4c51f3 /gnu/packages/time.scm
parent7ad7b0780617fa4055434590ca186a5d2cd87b59 (diff)
downloadguix-patches-b182121458c0126a05a41fec78a4f42472ba8081.tar
guix-patches-b182121458c0126a05a41fec78a4f42472ba8081.tar.gz
gnu: python-arrow: Honor #:tests? in 'check' phase.
* gnu/packages/time.scm (python-arrow)[arguments]: 'check' phase honors #:tests?.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 0e0eef6459..df4b8ac6f5 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2017, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2017, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
@@ -423,11 +423,12 @@ timestamps.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "pytest" "-vv" "tests"
- ;; python-dateutil doesn't recognize America/Nuuk.
- ;; Remove when python-dateutil > 2.8.1.
- "-k" "not test_parse_tz_name_zzz"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv" "tests"
+ ;; python-dateutil doesn't recognize America/Nuuk.
+ ;; Remove when python-dateutil > 2.8.1.
+ "-k" "not test_parse_tz_name_zzz")))))))
(native-inputs
`(;; For testing
("python-chai" ,python-chai)