summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:31:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-06-01 12:42:04 +0300
commit64c043e63a4be97f59fd1906c47973a74eedda67 (patch)
tree37b15dfb4830e4f874edca87b521b6e9cdc3c81b /gnu/packages/time.scm
parentb1f763de54dc2b8e240d0f01f7948ce76f67243e (diff)
parent75af73e1b7ac58770122d8831faa3a8158638bb0 (diff)
downloadguix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar
guix-patches-64c043e63a4be97f59fd1906c47973a74eedda67.tar.gz
Merge remote-tracking branch 'origin/master' into staging
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm75
1 files changed, 0 insertions, 75 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 2a77d4d4d2..eede7b9bd7 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -119,9 +119,6 @@ expressions.")
"This library provides a timezone database for Python.")
(license expat)))
-(define-public python2-tzdata
- (package-with-python2 python-pytzdata))
-
(define-public python-pytz
(package
(name "python-pytz")
@@ -143,9 +140,6 @@ higher. It also solves the issue of ambiguous times at the end of daylight
saving time. Almost all of the Olson timezones are supported.")
(license expat)))
-(define-public python2-pytz
- (package-with-python2 python-pytz))
-
(define-public python-pendulum
(package
(name "python-pendulum")
@@ -232,46 +226,6 @@ datetime module, available in Python 2.3+.")
;; BSD-3 still; but all new code is dual licensed (the user can choose).
(license (list bsd-3 asl2.0))))
-(define-public python2-dateutil
- (package
- (name "python2-dateutil")
- (version "2.8.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "python-dateutil" version))
- (sha256
- (base32
- "11iy7m4bp2lgfkcl0r6xzf34bvk7ppjmsyn2ygfikbi72v6cl8q1"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda _
- ;; Delete tests that depend on "freezegun" to avoid a
- ;; circular dependency.
- (delete-file "dateutil/test/test_utils.py")
- (delete-file "dateutil/test/test_rrule.py")
-
- ;; XXX: Fails to get timezone from /etc/localtime.
- (delete-file "dateutil/test/test_tz.py")
-
- (invoke "pytest" "-vv"))))))
- (native-inputs
- (list python2-pytest python2-pytest-cov python2-setuptools-scm))
- (propagated-inputs
- (list python2-six))
- (home-page "https://dateutil.readthedocs.io/en/stable/")
- (synopsis "Extensions to the standard datetime module")
- (description
- "The dateutil module provides powerful extensions to the standard
-datetime module, available in Python 2.3+.")
- ;; The license was changed from the three-clause BSD license to a dual
- ;; Apache 2.0/BSD-3 variant at 2017-12-01. Some code is only available as
- ;; BSD-3 still; but all new code is dual licensed (the user can choose).
- (license (list bsd-3 asl2.0))))
-
(define-public python-parsedatetime
(package
(name "python-parsedatetime")
@@ -294,9 +248,6 @@ datetime module, available in Python 2.3+.")
"Parse human-readable date/time text.")
(license asl2.0)))
-(define-public python2-parsedatetime
- (package-with-python2 python-parsedatetime))
-
(define-public python-ciso8601
(package
(name "python-ciso8601")
@@ -384,9 +335,6 @@ under several distributions that's hard or impossible to figure out.")
ISO 8601 dates, time and duration.")
(license bsd-3)))
-(define-public python2-isodate
- (package-with-python2 python-isodate))
-
(define-public python-iso8601
(package
(name "python-iso8601")
@@ -411,22 +359,8 @@ ISO 8601 dates, time and duration.")
(description
"This module parses the most common forms of ISO 8601 date strings (e.g.
@code{2007-01-14T20:34:22+00:00}) into @code{datetime} objects.")
- (properties `((python2-variant . ,(delay python2-iso8601))))
(license expat)))
-(define-public python2-iso8601
- (let ((base (package-with-python2 (strip-python2-variant python-iso8601))))
- (package
- (inherit base)
- (version "0.1.16")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "iso8601" version))
- (sha256
- (base32
- "0ny8dlycapxr8n2m13jxy0r7kbqvgypfshb6y7l981c0rivjylrn")))))))
-
(define-public python-monotonic
(package
(name "python-monotonic")
@@ -447,9 +381,6 @@ ISO 8601 dates, time and duration.")
value (in fractional seconds) of a clock which never goes backwards.")
(license asl2.0)))
-(define-public python2-monotonic
- (package-with-python2 python-monotonic))
-
(define-public python-pyrfc3339
(package
(name "python-pyrfc3339")
@@ -472,9 +403,6 @@ value (in fractional seconds) of a clock which never goes backwards.")
timestamps.")
(license expat)))
-(define-public python2-pyrfc3339
- (package-with-python2 python-pyrfc3339))
-
(define-public python-arrow
(package
(name "python-arrow")
@@ -532,9 +460,6 @@ datetime type.")
"This package contains a library for parsing ISO 8601 datetime strings.")
(license bsd-3)))
-(define-public python2-aniso8601
- (package-with-python2 python-aniso8601))
-
(define-public datefudge
(package
(name "datefudge")