summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-04-08 13:00:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-04-08 13:00:50 +0200
commit27783023993f9272ce422868d14529159c4a5218 (patch)
tree9013b08aa39e497b1fd8e01a05254278d83f0ff7 /gnu/packages/time.scm
parentbe1e842ad78ac6c52fc7790f4a3ffd716673c111 (diff)
parentba6f2bda18ed19fa486a9c3e2c3baea6c66c6867 (diff)
downloadguix-patches-27783023993f9272ce422868d14529159c4a5218.tar
guix-patches-27783023993f9272ce422868d14529159c4a5218.tar.gz
Merge branch 'master' into core-updates
Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 41a0802cde..a0599764cf 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,6 +37,7 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
#:use-module (gnu packages)
@@ -236,6 +238,34 @@ datetime module, available in Python 2.3+.")
(define-public python2-parsedatetime
(package-with-python2 python-parsedatetime))
+(define-public python-ciso8601
+ (package
+ (name "python-ciso8601")
+ (version "2.1.3")
+ (source
+ (origin
+ (method git-fetch)
+ ;; The PyPi distribution doesn't include the tests.
+ (uri (git-reference
+ (url "https://github.com/closeio/ciso8601.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g1aiyc1ayh0rnibyy416m5mmck38ksgdm3jsy0z3rxgmgb24951"))))
+ (build-system python-build-system)
+ ;; Pytz should only be required for Python 2, but the test suite fails
+ ;; without it.
+ (native-inputs
+ `(("python-pytz" ,python-pytz)))
+ (home-page "https://github.com/closeio/ciso8601")
+ (synopsis
+ "Fast ISO8601 date time parser")
+ (description
+ "The package ciso8601 converts ISO 8601 or RFC 3339 date time strings into
+Python datetime objects.")
+ (license expat)))
+
(define-public python-tzlocal
(package
(name "python-tzlocal")