summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorGuix Together <jgart@dismail.de>2021-12-18 15:27:55 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-12 22:55:06 +0100
commit0052c3b0458fba32920a1cfb48b8311429f0d6b5 (patch)
treef480d2fedb4dd8a096be53437552e7b2365044a4 /gnu/packages/time.scm
parent067dbee4971a91ce851b2fd3912c75acb0250fab (diff)
downloadguix-patches-0052c3b0458fba32920a1cfb48b8311429f0d6b5.tar
guix-patches-0052c3b0458fba32920a1cfb48b8311429f0d6b5.tar.gz
gnu: Add tz.
* gnu/packages/time.scm (tz): New variable. Co-authored-by: jgart <jgart@dismail.de> Co-authored-by: Jorge Acereda <jacereda@gmail.com> Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 97de5485ef..d4ff11228c 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -514,6 +514,39 @@ modifies the @code{time}, @code{gettimeofday} and @code{clock_gettime} system
calls.")
(license gpl2)))
+(define-public tz
+ (package
+ (name "tz")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/oz/tz")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1nbl13xd95np89sbx8fn0jqrh1iy17hsy70kq31hmcvyns8dljhg"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:go ,go-1.17
+ #:import-path "github.com/oz/tz"
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (invoke "go" "test" "-cover" import-path)))))))
+ (inputs
+ `(("github.com/charmbracelet/bubbletea" ,go-github-com-charmbracelet-bubbletea)
+ ("github.com/muesli/termenv" ,go-github-com-muesli-termenv)))
+ (home-page "https://github.com/oz/tz")
+ (synopsis "TUI time zone helper")
+ (description
+"@command{tz} helps you schedule things across time zones. It is an interactive
+TUI program that displays time across a few time zones of your choosing.")
+ (license gpl3+)))
+
(define-public countdown
(package
(name "countdown")