summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-10 02:50:54 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-10 15:59:44 +0100
commitf9c84cd4958edbe8e4f22e8e3660ed957c0453b1 (patch)
tree348636890e97d3de81b0d691dc092ebc310a6058 /gnu/packages/textutils.scm
parentf6e2d86f8e9d4d96954c4f2baa01d7c167626373 (diff)
downloadguix-patches-f9c84cd4958edbe8e4f22e8e3660ed957c0453b1.tar
guix-patches-f9c84cd4958edbe8e4f22e8e3660ed957c0453b1.tar.gz
gnu: utfcpp: Update to 2.3.5.
* gnu/packages/textutils.scm (utfcpp): Update to 2.3.5. [source]: Download tarball from new location. [build-system]: Switch to cmake-build-system. [arguments]: Use it, with custom ‘install’ phase. [native-inputs]: Remove unzip.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm43
1 files changed, 18 insertions, 25 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 2fb1d1495e..1f5fe6aba2 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,7 +38,6 @@
#:use-module (guix build-system ant)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system trivial)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
@@ -452,36 +452,29 @@ spreadsheets and outputs it in comma-separated-value format, and
(define-public utfcpp
(package
(name "utfcpp")
- (version "2.3.4")
+ (version "2.3.5")
(source (origin
(method url-fetch)
(uri
- (string-append
- "mirror://sourceforge/utfcpp/utf8cpp_2x/Release%20"
- version "/utf8_v"
- (string-map (lambda (x) (if (eq? x #\.) #\_ x)) version)
- ".zip"))
- (file-name (string-append name "-" version ".zip"))
+ (string-append "https://github.com/nemtrif/utfcpp/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1vqhs0aipcvvdrwcs7h3jsryg6mgbmc4s34n5cm6d36q4nxwwwrk"))))
- (build-system trivial-build-system)
+ "0gcqcfw19kfim8xw29xdp91l310yfjyrqdj2zsx8xx02dkpy1zzk"))))
+ (build-system cmake-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((source (assoc-ref %build-inputs "source"))
- (out (assoc-ref %outputs "out"))
- (unzip (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")))
- (mkdir-p out)
- (with-directory-excursion out
- (system* unzip source)
- (mkdir-p "share/doc")
- (rename-file "doc" "share/doc/utfcpp")
- (rename-file "source" "include"))))))
- (native-inputs `(("unzip" ,unzip)))
+ `(#:out-of-source? #f
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install ; no install target
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (include (string-append out "/include"))
+ (doc (string-append out "/share/doc/" ,name)))
+ (copy-recursively "source" include)
+ (install-file "README.md" doc)
+ #t))))))
(home-page "https://github.com/nemtrif/utfcpp")
(synopsis "Portable C++ library for handling UTF-8")
(description "UTF8-CPP is a C++ library for handling UTF-8 encoded text