summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-25 20:47:00 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-07-29 16:09:39 +0200
commitd050000a44dff70a98c53c3492002bbf345e4506 (patch)
tree81687c49f31a0513cb4290cbe5fe8049483b4a27 /gnu/packages/textutils.scm
parent42a0cfee6064c70441809ec81a601e671b5d0123 (diff)
downloadguix-patches-d050000a44dff70a98c53c3492002bbf345e4506.tar
guix-patches-d050000a44dff70a98c53c3492002bbf345e4506.tar.gz
gnu: go-github.com-mattn-go-runewidth: Update to 0.0.4-1.703b5e6.
* gnu/packages/textutils.scm (go-github.com-mattn-go-runewidth): Update to 0.0.4-1.703b5e6. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm47
1 files changed, 26 insertions, 21 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index d1dc14e6d7..2c520dfbdf 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -693,27 +693,32 @@ and Cython.")
(license license:expat))))
(define-public go-github.com-mattn-go-runewidth
- (package
- (name "go-github.com-mattn-go-runewidth")
- (version "0.0.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mattn/go-runewidth")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0vkrfrz3fzn5n6ix4k8s0cg0b448459sldq8bp4riavsxm932jzb"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/mattn/go-runewidth"))
- (synopsis "@code{runewidth} provides Go functions to work with string widths")
- (description
- "The @code{runewidth} library provides Go functions for padding,
-measuring and checking the width of strings, with support east asian text.")
- (home-page "https://github.com/jessevdk/go-flags")
- (license license:expat)))
+ (let ((commit "703b5e6b11ae25aeb2af9ebb5d5fdf8fa2575211")
+ (version "0.0.4")
+ (revision "1"))
+ (package
+ (name "go-github.com-mattn-go-runewidth")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mattn/runewidth")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0znpyz71gajx3g0j2zp63nhjj2c07g16885vxv4ykwnrfmzbgk4w"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/mattn/go-runewidth"))
+ (synopsis "@code{runewidth} provides Go functions to work with string widths")
+ (description
+ "The @code{runewidth} library provides Go functions for padding,
+measuring and checking the width of strings, with support for East Asian
+text.")
+ (home-page "https://github.com/mattn/runewidth")
+ (license license:expat))))
(define-public docx2txt
(package