summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-04-29 00:31:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-05-01 11:29:10 +0200
commitad35e2f8eca260a83fe029396d1cc5da5eefaf79 (patch)
treeac55fcb4fb1328dda5c39609c5a44ea4c2e8b0a6 /gnu/packages/textutils.scm
parente64af2060e8cfa48e74b887281acb3fd4c7e7781 (diff)
downloadguix-patches-ad35e2f8eca260a83fe029396d1cc5da5eefaf79.tar
guix-patches-ad35e2f8eca260a83fe029396d1cc5da5eefaf79.tar.gz
gnu: ustr: Omit static libraries.
* gnu/packages/textutils.scm (ustr)[arguments]: Add a new 'omit-static-libraries phase.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index a51d689134..ab34373705 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -336,6 +336,11 @@ input bits thoroughly but are not suitable for cryptography.")
"echo 1"
"echo 0"))
(("\\./autoconf_vsnprintf") "echo 0"))))
+ (add-after 'unpack 'omit-static-libraries
+ ;; These are needed to build & test ustr, but don't install them.
+ (lambda _
+ (substitute* "Makefile"
+ ((".*install.*LIB_STATIC.*") ""))))
(add-after 'unpack 'disable-check-for-stdint
(lambda _
;; Of course we have stdint.h, just not in /usr/include