summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-19 22:01:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-19 22:01:53 +0200
commit74247b80e5f8e1b385dbcc82df4851c2ee5792f3 (patch)
tree510a6a146a815f32b49f4ec9d4649659130d8c13 /gnu/packages/textutils.scm
parent0c842e3a59da42d344f054b246e870eba708f779 (diff)
downloadguix-patches-74247b80e5f8e1b385dbcc82df4851c2ee5792f3.tar
guix-patches-74247b80e5f8e1b385dbcc82df4851c2ee5792f3.tar.gz
gnu: Add python-pandocfilters.
* gnu/packages/textutils.scm (python-pandocfilters): New variable.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index c204fb9b92..79835e8578 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -851,3 +851,28 @@ Mainland China, Taiwan, and Hong-Kong.")
hosts and terminals. It converts input kanji code to designated kanji code
such as ISO-2022-JP, Shift_JIS, EUC-JP, UTF-8, UTF-16 or UTF-32.")
(license license:zlib))))
+
+(define-public python-pandocfilters
+ (package
+ (name "python-pandocfilters")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pandocfilters" version))
+ (sha256
+ (base32
+ "1a8d9b7s48gmq9zj0pmbyv2sivn5i7m6mybgpkk4jm5vd7hp1pdk"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/jgm/pandocfilters")
+ (synopsis "Python module for writing Pandoc filters")
+ (description "Pandoc is a powerful utility to transform various
+input formats into a wide range of output formats. To alter the
+exported output document, Pandoc allows the usage of filters, which
+are pipes that read a JSON serialization of the Pandoc AST from stdin,
+transform it in some way, and write it to stdout. It allows therefore
+to alter the processing of Pandoc's supported input formats, for
+instance one can add new syntax elements to markdown, etc.
+
+This package provides Python bindings.")
+ (license license:bsd-3)))