summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-12 21:25:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-12 21:26:40 +0200
commit73092df4686074572e79a54946d9b62f495f58a7 (patch)
tree393c715d35b22599cc0414b14a01976cb57c9f14 /gnu/packages/textutils.scm
parent2b16dbc3da4a8bd705f156ad5bd675e6f1f5fd56 (diff)
downloadguix-patches-73092df4686074572e79a54946d9b62f495f58a7.tar
guix-patches-73092df4686074572e79a54946d9b62f495f58a7.tar.gz
gnu: libgtextutils: Hide default GCC.
* gnu/packages/textutils.scm (libgtextutils)[arguments]: Add phase hide-default-gcc.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm19
1 files changed, 15 insertions, 4 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 3c765aa887..de68645489 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
@@ -235,14 +235,25 @@ nested include statements).")
(base32 "0jiybkb2z58wa2msvllnphr4js2hvjvh988pavb3mzkgr6ihwbkr"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'bootstrap
- (lambda _ (invoke "sh" "reconf"))))))
+ (lambda _ (invoke "sh" "reconf")))
+ (add-after 'set-paths 'hide-default-gcc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gcc (assoc-ref inputs "gcc")))
+ ;; Remove the default GCC from CPLUS_INCLUDE_PATH to prevent
+ ;; conflicts with the GCC 5 input.
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-join
+ (delete (string-append gcc "/include/c++")
+ (string-split (getenv "CPLUS_INCLUDE_PATH") #\:))
+ ":"))
+ #t))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("gcc" ,gcc-5) ;; doesn't build with later versions
+ ("gcc@5" ,gcc-5) ; doesn't build with later versions
("libtool" ,libtool)))
(home-page "https://github.com/agordon/libgtextutils")
(synopsis "Gordon's text utils library")