summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-16 01:57:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-16 14:30:22 +0200
commit63f2de031c7ddbfb0697cccc8f916bd29eaa85de (patch)
treefae6662e8ac27f029a2d96ab7b5317f61536fc02 /gnu/packages/textutils.scm
parentb273158bb41e3e4b5e5ccf1077bab852e9df4b5d (diff)
downloadguix-patches-63f2de031c7ddbfb0697cccc8f916bd29eaa85de.tar
guix-patches-63f2de031c7ddbfb0697cccc8f916bd29eaa85de.tar.gz
gnu: utf8proc: Factor out UNICODE_VERSION.
* gnu/packages/textutils.scm (utf8proc)[native-inputs]: Use a single UNICODE_VERSION.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm37
1 files changed, 20 insertions, 17 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index c2184de46b..54267bfe9b 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -151,24 +151,27 @@ libenca and several charset conversion libraries and tools.")
(sha256
(base32 "1i42hqwc8znqii9brangwkxk5cyc2lk95ip405fg88zr7z2ncr34"))))
(build-system gnu-build-system)
- (native-inputs ;test data that is otherwise downloaded with curl
- `(("NormalizationTest.txt"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
- "NormalizationTest.txt"))
- (sha256
- (base32 "0hb97k9xv1lr847hwz0719ksqy39s47xw6k01dgs1368jdibvawc"))))
- ("GraphemeBreakTest.txt"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://www.unicode.org/Public/12.1.0/ucd/"
- "auxiliary/GraphemeBreakTest.txt"))
- (sha256
- (base32 "0qc90ppmrwfn3y9cdn8jcjrn7qpdf0fhxkwh945yp4rvh37mbgcm"))))
+ (native-inputs
+ (let ((UNICODE_VERSION "12.1.0")) ; defined in data/Makefile
+ ;; Test data that is otherwise downloaded with curl.
+ `(("NormalizationTest.txt"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://www.unicode.org/Public/"
+ UNICODE_VERSION "/ucd/NormalizationTest.txt"))
+ (sha256
+ (base32 "0hb97k9xv1lr847hwz0719ksqy39s47xw6k01dgs1368jdibvawc"))))
+ ("GraphemeBreakTest.txt"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://www.unicode.org/Public/"
+ UNICODE_VERSION
+ "/ucd/auxiliary/GraphemeBreakTest.txt"))
+ (sha256
+ (base32 "0qc90ppmrwfn3y9cdn8jcjrn7qpdf0fhxkwh945yp4rvh37mbgcm"))))
- ;; For tests.
- ("perl" ,perl)))
+ ;; For tests.
+ ("perl" ,perl))))
(arguments
'(#:make-flags (list "CC=gcc"
(string-append "prefix=" (assoc-ref %outputs "out")))