summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2016-03-26 18:28:31 +0100
committerAlex Kost <alezost@gmail.com>2016-04-01 11:38:06 +0300
commit2d8cf0b3e722d1e22a38081a03aa9af70e452940 (patch)
tree671ff226b885af69bea47da41f3ba30d1fc1331c /gnu/packages/textutils.scm
parent52af45adeb13d5ca4757ad8e2e4388de265b3de3 (diff)
downloadguix-patches-2d8cf0b3e722d1e22a38081a03aa9af70e452940.tar
guix-patches-2d8cf0b3e722d1e22a38081a03aa9af70e452940.tar.gz
gnu: Add oniguruma.
* gnu/packages/textutils.scm (oniguruma): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 73a0532478..71cf25b224 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -271,3 +272,23 @@ Consequently, the computation has a flat performance characteristic,
correlated with data variation rather than file size. pfff can be as reliable
as existing hashing techniques, with provably negligible risk of collisions.")
(license license:bsd-3)))
+
+(define-public oniguruma
+ (package
+ (name "oniguruma")
+ (version "5.9.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/kkos/"
+ "oniguruma/releases/download/v" version
+ "/onig-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19s79vsclqn170mw0ajwv7j37qsbn4f1yjz3yavnhvva6c820r6m"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/kkos/oniguruma")
+ (synopsis "Regular expression library")
+ (description "Oniguruma is a regular expressions library. The special
+characteristic of this library is that different character encoding for every
+regular expression object can be specified.")
+ (license license:bsd-2)))