summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-12-23 19:46:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2018-12-23 19:48:24 +0200
commit1506d491f93e1d0ac453392401d503b80bf4fecb (patch)
treed7d430e0aac94d8862cf7e86d96fbc29c16c0526 /gnu/packages/textutils.scm
parentbf5af9342c6dd364242c162db00436c9708e8d5b (diff)
downloadguix-patches-1506d491f93e1d0ac453392401d503b80bf4fecb.tar
guix-patches-1506d491f93e1d0ac453392401d503b80bf4fecb.tar.gz
gnu: opencc: Unbundle rapidjson.
* gnu/packages/textutils.scm (opencc)[source]: Add snippet to remove rapidjson. [arguments]: Add custom phase to substitute rapidjson. [native-inputs]: Add rapidjson.
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm24
1 files changed, 21 insertions, 3 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 1ea9c95407..91bc64bc1f 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -52,7 +52,8 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
- #:use-module (gnu packages slang))
+ #:use-module (gnu packages slang)
+ #:use-module (gnu packages web))
(define-public dos2unix
(package
@@ -764,10 +765,27 @@ indentation.
(commit (string-append "ver." version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))))
+ (base32
+ "1pv5md225qwhbn8ql932zdg6gh1qlx3paiajaks8gfsa07yzvhr4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; TODO: Unbundle tclap, darts-clone, gtest
+ (delete-file-recursively "deps/rapidjson-0.11") #t))))
(build-system cmake-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-3rd-party-references
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((rapidjson (assoc-ref inputs "rapidjson")))
+ (substitute* "src/CMakeLists.txt"
+ (("../deps/rapidjson-0.11")
+ (string-append rapidjson "/include/rapidjson")))
+ #t))))))
(native-inputs
- `(("python" ,python-wrapper)))
+ `(("python" ,python-wrapper)
+ ("rapidjson" ,rapidjson)))
(home-page "https://github.com/BYVoid/OpenCC")
(synopsis "Convert between Traditional Chinese and Simplified Chinese")
(description "Open Chinese Convert (OpenCC) converts between Traditional