summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-01 10:27:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-08-01 10:27:38 +0200
commiteaf5df6b11690310043a875a955a79f712aaf06a (patch)
treef0dcbe4d9c5a7726d4997f5c3ea22a1a6521e584 /gnu/packages/text-editors.scm
parent1619d350a354bb6c04a34baa5bf4a2ac29a5ebe5 (diff)
downloadguix-patches-eaf5df6b11690310043a875a955a79f712aaf06a.tar
guix-patches-eaf5df6b11690310043a875a955a79f712aaf06a.tar.gz
gnu: texmacs: Update to 1.99.13.
* gnu/packages/text-editors.scm (texmacs): Update to 1.99.13. [source]: Remove unnecessary snippet. [native-inputs]: Add xdg-utils. [inputs]: Replace qt-4 with qtbase. [arguments]: Add a phase to fix hard-coded paths. [description]: Fix small typo.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index de1bf71f80..81475b4d0f 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -46,6 +46,7 @@
#:use-module (gnu packages code)
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
@@ -700,32 +701,35 @@ editors.")
(define-public texmacs
(package
(name "texmacs")
- (version "1.99.11")
+ (version "1.99.13")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.texmacs.org/Download/ftp/tmftp/"
"source/TeXmacs-" version "-src.tar.gz"))
(sha256
- (base32 "12bp0f34izzqimz49lfpgf4lyz3h45s9xbmk8v6zsawdjki76alg"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (delete-file-recursively "3rdparty")
- #t))))
+ (base32 "1d590yyanh2ar88pd0ns4mf616bq1lq4cwg93m863anhir5irb82"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("xdg-utils" ,xdg-utils))) ;for xdg-icon-resource
(inputs
`(("freetype" ,freetype)
("guile" ,guile-1.8)
("perl" ,perl)
("python" ,python-wrapper)
- ("qt" ,qt-4)))
+ ("qt" ,qtbase)))
(arguments
`(#:tests? #f ; no check target
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-icon-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "packages/linux/icons.sh"
+ (("/usr/share")
+ (string-append out "/share")))
+ #t)))
(add-before 'configure 'gzip-flags
(lambda _
(substitute* "Makefile.in"
@@ -733,10 +737,10 @@ editors.")
(synopsis "Editing platform with special features for scientists")
(description
"GNU TeXmacs is a text editing platform which is specialized for
-scientists. It is ideal for editing structured documents with different
-types of content. It has robust support for mathematical formulas and plots.
- It can also act as an interface to external mathematical programs such as R
-and Octave. TeXmacs is completely extensible via Guile.")
+scientists. It is ideal for editing structured documents with different types
+of content. It has robust support for mathematical formulas and plots. It
+can also act as an interface to external mathematical programs such as R and
+Octave. TeXmacs is completely extensible via Guile.")
(license license:gpl3+)
(home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))