summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-07-26 11:11:11 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-26 11:11:11 +0200
commitbcd757fdb49753f41a7ee4f0181cdef582705a6a (patch)
tree67a40a039f20f74b41d991dc2605ab2ac0187c60 /gnu/packages/text-editors.scm
parenta5130d10fa39fa9a05edfe6934b2c88a33ec906f (diff)
downloadguix-patches-bcd757fdb49753f41a7ee4f0181cdef582705a6a.tar
guix-patches-bcd757fdb49753f41a7ee4f0181cdef582705a6a.tar.gz
gnu: mg: Move to (gnu packages text-editors).
* gnu/packages/mg.scm: Remove. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove it. * gnu/packages/text-editors.scm (mg): New variable.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 56049eb510..756c2beab2 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Feng Shu <tumashu@163.com>
;;; Copyright © 2017 ng0 <ng0@no-reply.pragmatique.xyz>
+;;; Copyright © 2014 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -35,6 +36,7 @@
#:use-module (gnu packages gcc)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages libbsd)
#:use-module (gnu packages lua)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
@@ -228,3 +230,52 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
16, 32, and 64-bit CPUs.")
(supported-systems '("x86_64-linux" "i686-linux"))
(license license:gpl2+)))
+
+(define-public mg
+ (package
+ (name "mg")
+ (version "20161005")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://homepage.boetes.org/software/mg/mg-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0qaydk2cy765n9clghmi5gdnpwn15y2v0fj6r0jcm0v7d89vbz5p"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (substitute* "GNUmakefile"
+ (("/usr/bin/") ""))))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libbsd" ,libbsd)
+ ("ncurses" ,ncurses)))
+ (arguments
+ ;; No test suite available.
+ '(#:tests? #f
+ #:make-flags (list (string-append "prefix=" %output)
+ "CURSES_LIBS=-lncurses"
+ "CC=gcc")
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'install 'patch-tutorial-location
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "mg.1"
+ (("/usr") (assoc-ref outputs "out")))
+ #t))
+ (add-after 'install 'install-tutorial
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/mg")))
+ (install-file "tutorial" doc)
+ #t))))))
+ (home-page "http://homepage.boetes.org/software/mg/")
+ (synopsis "Microscopic GNU Emacs clone")
+ (description
+ "Mg (mg) is a GNU Emacs style editor, with which it is \"broadly\"
+compatible. This is a portable version of the mg maintained by the OpenBSD
+team.")
+ (license license:public-domain)))