summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-04-26 19:25:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-04-26 21:08:58 +0200
commita4d8b386ac9b44ac08bdedf4dcb4b7becef4df53 (patch)
treef3561754e094d03ea4c60f16d900290f5db44228 /gnu/packages/text-editors.scm
parent11edb2474c96ceaf3286e9e7cac2aeaf27b5d729 (diff)
downloadguix-patches-a4d8b386ac9b44ac08bdedf4dcb4b7becef4df53.tar
guix-patches-a4d8b386ac9b44ac08bdedf4dcb4b7becef4df53.tar.gz
gnu: mg: Update to 20180408.
* gnu/packages/text-editors.scm (mg): Update to 20180408. [source]: Switch from discontinued proper releases to a git tag.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 0e6539436d..d12e3d706f 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -237,14 +237,16 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
(define-public mg
(package
(name "mg")
- (version "20171014")
+ (version "20180408")
(source (origin
- (method url-fetch)
- (uri (string-append "https://homepage.boetes.org/software/mg/mg-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hboetes/mg")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0hakfikzsml7z0hja8m8mcahrmfy2piy81bq9nccsjplyfc9clai"))
+ "06w86xk7sjl2x2h3z6msn8kpmwj05qdimcym77wzhz5s94dzh1bl"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -262,7 +264,7 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
#:make-flags (list (string-append "prefix=" %output)
"CC=gcc")
#:phases (modify-phases %standard-phases
- (delete 'configure)
+ (delete 'configure) ; no configure script
(add-before 'build 'correct-location-of-difftool
(lambda _
(substitute* "buffer.c"