summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-07-13 20:17:51 +0100
committerPierre Langlois <pierre.langlois@gmx.com>2021-07-14 09:59:45 +0100
commit681a0c75182e3f5cc5d8dba063451a96d64fa23c (patch)
tree782a17f079a51dfb48f22f062c7c2c3001c1935a /gnu/packages/text-editors.scm
parent14bf5890c37cf0cf1027341cb6d6cb17d0061f91 (diff)
downloadguix-patches-681a0c75182e3f5cc5d8dba063451a96d64fa23c.tar
guix-patches-681a0c75182e3f5cc5d8dba063451a96d64fa23c.tar.gz
gnu: mg: Enable cross-compilation.
* gnu/packages/text-editors.scm (mg)[arguments]: Use cc-for-target. Add phase to substitute pkg-config with the target's pkg-config. Remote #t return from phases.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 965ed6b9e7..11332fab0b 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2020 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -527,28 +528,32 @@ Wordstar-, EMACS-, Pico, Nedit or vi-like key bindings. e3 can be used on
("ncurses" ,ncurses)))
(arguments
;; No test suite available.
- '(#:tests? #f
+ `(#:tests? #f
#:make-flags (list (string-append "prefix=" %output)
- "CC=gcc")
+ (string-append "CC=" ,(cc-for-target)))
#:phases (modify-phases %standard-phases
(delete 'configure) ; no configure script
(add-before 'build 'correct-location-of-difftool
(lambda _
(substitute* "buffer.c"
(("/usr/bin/diff")
- (which "diff")))
- #t))
+ (which "diff")))))
+ (add-before 'build 'pkg-config-for-cross-compiling-target
+ (lambda _
+ (substitute* "GNUmakefile"
+ (("pkg-config")
+ (or (which "pkg-config")
+ (string-append ,(%current-target-system)
+ "-pkg-config"))))))
(add-before 'install 'patch-tutorial-location
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "mg.1"
- (("/usr") (assoc-ref outputs "out")))
- #t))
+ (("/usr") (assoc-ref outputs "out")))))
(add-after 'install 'install-tutorial
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(doc (string-append out "/share/doc/mg")))
- (install-file "tutorial" doc)
- #t))))))
+ (install-file "tutorial" doc)))))))
(home-page "https://homepage.boetes.org/software/mg/")
(synopsis "Microscopic GNU Emacs clone")
(description