summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-18 11:08:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-29 18:46:11 +0200
commit2207d522d41af2e79485ad74e29c3dedceafd060 (patch)
treef123053caa0790fc3b63398b45845eed58aa4b5a /gnu/packages/text-editors.scm
parent7735c4bfef6c4d6d9cc9be55e9baa7b83b9eb40e (diff)
downloadguix-patches-2207d522d41af2e79485ad74e29c3dedceafd060.tar
guix-patches-2207d522d41af2e79485ad74e29c3dedceafd060.tar.gz
gnu: Add fe.
* gnu/packages/text-editors.scm (fe): New variable.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 4412d54579..432e79e350 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -41,6 +41,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
@@ -567,3 +568,55 @@ The basic features of Geany are:
@item extensibility through plugins
@end itemize")
(license license:gpl2+)))
+
+(define-public fe
+ (package
+ (name "fe")
+ ;; Stable release is 1.8. However, this development version
+ ;; introduces support for UTF-8.
+ (version "2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.moria.de/~michael/fe/"
+ "fe-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1hwws7si1752z6hp61zxznvgsb6846lp8zl1hn5ddhsbafwalwb9"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no test
+ ;; Sendmail is only used to send a crash log. Disable the
+ ;; feature since it is (1) undocumented (2) not very useful.
+ #:configure-flags (list "--disable-sendmail")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-" ,version)))
+ (for-each (lambda (f) (install-file f doc))
+ '("fe.doc" "fe.html" "fe.ps" "feref.ps" "README"))
+ #t))))))
+ (native-inputs
+ `(("gettext" ,gettext-minimal)))
+ (inputs
+ `(("ncurses" ,ncurses)))
+ (home-page "http://www.moria.de/~michael/fe/")
+ (synopsis "Small folding editor")
+ (description "Fe is a small folding editor. It allows to fold
+arbitrary text regions; it is not bound to syntactic units.
+
+Fe has no configuration or extension language and requires no setup.
+Its user interface is emacs-like and it has menues for the very most
+important functions to help beginners. Further there is a reference
+card. It offers:
+
+@itemize
+@item Regions and Emacs-like kill ring
+@item Incremental search
+@item Keyboard macros
+@item Editing binary files
+@item Multiple windows and views
+@item Compose function for Latin 1 characters
+@end itemize")
+ (license license:gpl2+)))