summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-15 23:10:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-15 23:12:56 +0100
commite703f6d8ef354d2c394c4f68bde5b9bf66237f70 (patch)
tree2424fcc45caada37ba5bc3dd099372c2aae4accd /gnu/packages/texinfo.scm
parent34982a46225d03191f87752d760d54f4782751fd (diff)
downloadguix-patches-e703f6d8ef354d2c394c4f68bde5b9bf66237f70.tar
guix-patches-e703f6d8ef354d2c394c4f68bde5b9bf66237f70.tar.gz
gnu: Add pinfo.
* gnu/packages/texinfo.scm (pinfo): New variable.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm55
1 files changed, 54 insertions, 1 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 7f95c29b9e..de3f7c5d35 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,11 +26,15 @@
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages ncurses)
- #:use-module (gnu packages perl))
+ #:use-module (gnu packages perl)
+ #:use-module (gnu packages readline))
(define-public texinfo
(package
@@ -183,3 +188,51 @@ of the GNU Texinfo implementation) do not intend to make further releases of
Texi2HTML.")
;; Files in /lib under lgpl2.1+ and x11
(license gpl2+)))
+
+(define-public pinfo
+ (package
+ (name "pinfo")
+ (version "0.6.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/baszoetekouw/pinfo.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "173d2p22irwiabvr4z6qvr6zpr6ysfkhmadjlyhyiwd7z62larvy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-Werror
+ (lambda _
+ (substitute* "configure.ac"
+ (("-Werror") ""))
+ #t))
+ (add-after 'unpack 'embed-reference-to-clear
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("src/manual.c"
+ "src/mainfunction.c"
+ "src/utils.c")
+ (("\"clear\"")
+ (string-append "\"" (which "clear") "\"")))
+ #t)))))
+ (inputs
+ `(("ncurses" ,ncurses)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gnu-gettext)
+ ("libtool" ,libtool)
+ ("texinfo" ,texinfo)))
+ (home-page "https://github.com/baszoetekouw/pinfo")
+ (synopsis "Lynx-style Info file and man page reader")
+ (description
+ "Pinfo is an Info file viewer. Pinfo is similar in use to the Lynx web
+browser. You just move across info nodes, and select links, follow them, etc.
+It supports many colors. Pinfo also supports viewing of manual pages -- they
+are colorized like in the midnight commander's viewer, and additionaly they
+are hypertextualized.")
+ (license gpl2+)))