summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 15:08:01 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-16 15:08:08 +0100
commit8c4c5bf86ac57e2923f51f9dcc5794dedb85ed3c (patch)
treea1f7abdc5fe99de71377d0d6efab0dff298b5858 /gnu/packages/texinfo.scm
parentd0ef3a00486a868ff490257013650fa60928214d (diff)
downloadguix-patches-8c4c5bf86ac57e2923f51f9dcc5794dedb85ed3c.tar
guix-patches-8c4c5bf86ac57e2923f51f9dcc5794dedb85ed3c.tar.gz
Revert "gnu: info-reader: Fix cross-compilation."
This reverts commit 614a1e3fa2d731d4719f03912b1b87fb4fd309cb. This is broken on master with the following error: output (`/gnu/store/6rnhfi8zrdajbahbq9ii8bpj7mwfcjba-info-reader-6.6') is not allowed to refer to path `/gnu/store/ziinjmbnq004866mwjrczsk12wf35qb8-perl-5.30.0' build of /gnu/store/nnfvr10713khxp1bkbpwi5wxbj8cm4wb-info-reader-6.6.drv failed View build log at '/var/log/guix/drvs/nn/fvr10713khxp1bkbpwi5wxbj8cm4wb-info-reader-6.6.drv.bz2'.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index de3f7c5d35..1162e77b07 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -3,7 +3,6 @@
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -115,32 +114,32 @@ is on expressing the content semantically, avoiding physical markup commands.")
(inherit texinfo)
(name "info-reader")
(arguments
- `(,@(substitute-keyword-arguments (package-arguments texinfo)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'install 'keep-only-info-reader
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Remove everything but 'bin/info' and associated
- ;; files.
- (define (files)
- (scandir "." (lambda (file)
- (not (member file '("." ".."))))))
-
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion out
- (for-each delete-file-recursively
- (fold delete (files) '("bin" "share"))))
- (with-directory-excursion (string-append out "/bin")
- (for-each delete-file (delete "info" (files))))
- (with-directory-excursion (string-append out "/share")
- (for-each delete-file-recursively
- (fold delete (files)
- '("info" "locale"))))
- #t))))))
- #:disallowed-references ,(assoc-ref (package-inputs texinfo)
+ `(#:disallowed-references ,(assoc-ref (package-inputs texinfo)
"perl")
+
#:modules ((ice-9 ftw) (srfi srfi-1)
- ,@%gnu-build-system-modules)))
+ ,@%gnu-build-system-modules)
+
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'keep-only-info-reader
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Remove everything but 'bin/info' and associated
+ ;; files.
+ (define (files)
+ (scandir "." (lambda (file)
+ (not (member file '("." ".."))))))
+
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion out
+ (for-each delete-file-recursively
+ (fold delete (files) '("bin" "share"))))
+ (with-directory-excursion (string-append out "/bin")
+ (for-each delete-file (delete "info" (files))))
+ (with-directory-excursion (string-append out "/share")
+ (for-each delete-file-recursively
+ (fold delete (files)
+ '("info" "locale"))))
+ #t))))))
(synopsis "Standalone Info documentation reader")))
(define-public texi2html