summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-14 17:46:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-14 17:49:09 +0100
commit7b90379db8adae9b23da4d5b7c7d3ec61d0e59a1 (patch)
tree4803086e5ea2074d58cddcc21df44b0a0b0b175f /gnu/packages/texinfo.scm
parent2f014c85f742148971801cfc4f29ae7f5e734c99 (diff)
downloadguix-patches-7b90379db8adae9b23da4d5b7c7d3ec61d0e59a1.tar
guix-patches-7b90379db8adae9b23da4d5b7c7d3ec61d0e59a1.tar.gz
gnu: info-reader: Fix cross-compilation.
* gnu/packages/texinfo.scm (info-reader)[arguments]: Add keep-only-info-reader phase to inherited texinfo package phases, so that fix-cross-configure phase is preserved.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index ef3dfba09e..c755790448 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -159,32 +160,32 @@ is on expressing the content semantically, avoiding physical markup commands.")
(inherit texinfo)
(name "info-reader")
(arguments
- `(#:disallowed-references ,(assoc-ref (package-inputs texinfo)
- "perl")
+ `(,@(substitute-keyword-arguments (package-arguments texinfo)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'keep-only-info-reader
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Remove everything but 'bin/info' and associated
+ ;; files.
+ (define (files)
+ (scandir "." (lambda (file)
+ (not (member file '("." ".."))))))
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion out
+ (for-each delete-file-recursively
+ (fold delete (files) '("bin" "share"))))
+ (with-directory-excursion (string-append out "/bin")
+ (for-each delete-file (delete "info" (files))))
+ (with-directory-excursion (string-append out "/share")
+ (for-each delete-file-recursively
+ (fold delete (files)
+ '("info" "locale"))))
+ #t))))))
+ #:disallowed-references ,(assoc-ref (package-inputs texinfo)
+ "perl")
#:modules ((ice-9 ftw) (srfi srfi-1)
- ,@%gnu-build-system-modules)
-
- #:phases (modify-phases %standard-phases
- (add-after 'install 'keep-only-info-reader
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Remove everything but 'bin/info' and associated
- ;; files.
- (define (files)
- (scandir "." (lambda (file)
- (not (member file '("." ".."))))))
-
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion out
- (for-each delete-file-recursively
- (fold delete (files) '("bin" "share"))))
- (with-directory-excursion (string-append out "/bin")
- (for-each delete-file (delete "info" (files))))
- (with-directory-excursion (string-append out "/share")
- (for-each delete-file-recursively
- (fold delete (files)
- '("info" "locale"))))
- #t))))))
+ ,@%gnu-build-system-modules)))
(synopsis "Standalone Info documentation reader")))
(define-public texi2html