summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-10-01 19:59:55 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-10-01 22:16:22 +0300
commit64df08f0cfac8f7a329002afa3461fd62a4b229c (patch)
tree019909423138ceb49cdd86f1af48d366503db68f /gnu/packages/texinfo.scm
parentb83ad3ace56c65a367e8f58c7b78323cf251b94b (diff)
parent0ef1c223071869488c35b72b7407234c11425589 (diff)
downloadguix-patches-64df08f0cfac8f7a329002afa3461fd62a4b229c.tar
guix-patches-64df08f0cfac8f7a329002afa3461fd62a4b229c.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 5bf3a97e81..29455b911d 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2015, 2016, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
@@ -31,6 +31,7 @@
#:use-module (gnu packages ncurses))
(define-public texinfo
+ ;; TODO: Merge with 'texinfo-latest' on the next core-updates.
(package
(name "texinfo")
(version "6.4")
@@ -63,6 +64,19 @@ their source and the command-line Info reader. The emphasis of the language
is on expressing the content semantically, avoiding physical markup commands.")
(license gpl3+)))
+(define-public texinfo-latest
+ ;; TODO: Turn this into 'texinfo' on the next core-updates cycle.
+ (package (inherit texinfo)
+ (version "6.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/texinfo/texinfo-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0qjzvbvnv9003xdrcpi3jp7y68j4hq2ciw9frh2hghh698zlnxvp"))))
+ (native-inputs '())))
+
(define-public texinfo-5
(package (inherit texinfo)
(version "5.2")