summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-14 17:46:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-15 15:48:15 +0100
commit614a1e3fa2d731d4719f03912b1b87fb4fd309cb (patch)
tree30129396bb00241094535ed15b5740e656778ce8 /gnu/packages/texinfo.scm
parent6e10ac0780203e5efd0469ed9d8be4f76cfb8303 (diff)
downloadguix-patches-614a1e3fa2d731d4719f03912b1b87fb4fd309cb.tar
guix-patches-614a1e3fa2d731d4719f03912b1b87fb4fd309cb.tar.gz
gnu: info-reader: Fix cross-compilation.
* gnu/packages/texinfo.scm (info-reader)[arguments]: Add keep-only-info-reader phase to inherited texinfo package phases, so that fix-cross-configure phase is preserved.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm49
1 files changed, 25 insertions, 24 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 1edeea2425..3d0894b84f 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -108,32 +109,32 @@ is on expressing the content semantically, avoiding physical markup commands.")
(inherit texinfo)
(name "info-reader")
(arguments
- `(#:disallowed-references ,(assoc-ref (package-inputs texinfo)
- "perl")
+ `(,@(substitute-keyword-arguments (package-arguments texinfo)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'install 'keep-only-info-reader
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Remove everything but 'bin/info' and associated
+ ;; files.
+ (define (files)
+ (scandir "." (lambda (file)
+ (not (member file '("." ".."))))))
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion out
+ (for-each delete-file-recursively
+ (fold delete (files) '("bin" "share"))))
+ (with-directory-excursion (string-append out "/bin")
+ (for-each delete-file (delete "info" (files))))
+ (with-directory-excursion (string-append out "/share")
+ (for-each delete-file-recursively
+ (fold delete (files)
+ '("info" "locale"))))
+ #t))))))
+ #:disallowed-references ,(assoc-ref (package-inputs texinfo)
+ "perl")
#:modules ((ice-9 ftw) (srfi srfi-1)
- ,@%gnu-build-system-modules)
-
- #:phases (modify-phases %standard-phases
- (add-after 'install 'keep-only-info-reader
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Remove everything but 'bin/info' and associated
- ;; files.
- (define (files)
- (scandir "." (lambda (file)
- (not (member file '("." ".."))))))
-
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion out
- (for-each delete-file-recursively
- (fold delete (files) '("bin" "share"))))
- (with-directory-excursion (string-append out "/bin")
- (for-each delete-file (delete "info" (files))))
- (with-directory-excursion (string-append out "/share")
- (for-each delete-file-recursively
- (fold delete (files)
- '("info" "locale"))))
- #t))))))
+ ,@%gnu-build-system-modules)))
(synopsis "Standalone Info documentation reader")))
(define-public texi2html