summaryrefslogtreecommitdiff
path: root/gnu/packages/texinfo.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-04 19:18:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-04 19:18:10 +0200
commit4ab97ef18fa9923f00865c2d3f79bead247aa5e3 (patch)
tree763f2a1fe86fa0d147f9fae826cf5c0798b4b14d /gnu/packages/texinfo.scm
parent7c93edb93eb5700e1fd3a949195b4edebf6fdf2c (diff)
downloadguix-patches-4ab97ef18fa9923f00865c2d3f79bead247aa5e3.tar
guix-patches-4ab97ef18fa9923f00865c2d3f79bead247aa5e3.tar.gz
Revert "gnu: texinfo: Fix cross-compilation."
This causes too many rebuilds for the master branch. This reverts commit 210b6412eeb915bba0848c1a947a24bfc51b9efc.
Diffstat (limited to 'gnu/packages/texinfo.scm')
-rw-r--r--gnu/packages/texinfo.scm24
1 files changed, 2 insertions, 22 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index c661dc23ae..fa98bd56b8 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -42,28 +42,8 @@
(base32
"0qjzvbvnv9003xdrcpi3jp7y68j4hq2ciw9frh2hghh698zlnxvp"))))
(build-system gnu-build-system)
- (arguments
- ;; When cross-compiling, the package is configured twice: once with the
- ;; native compiler and once with the cross-compiler. During the configure
- ;; with the native compiler, the environment is reset. This leads to
- ;; multiple environment variables missing. Do not reset the environment
- ;; to prevent that.
- (if (%current-target-system)
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'fix-cross-configure
- (lambda _
- (substitute* "configure"
- (("env -i")
- "env "))
- #t))))
- '()))
- (inputs `(("ncurses" ,ncurses)))
- ;; When cross-compiling, texinfo will build some of its own binaries with
- ;; the native compiler. This means ncurses is needed both in both inputs
- ;; and native-inputs.
- (native-inputs `(("perl" ,perl)
- ("ncurses" ,ncurses)))
+ (inputs `(("ncurses" ,ncurses)
+ ("perl" ,perl)))
(native-search-paths
;; This is the variable used by the standalone Info reader.